Arris BGW210 and IP Passthrough

Internet access discussion, including Fusion, IP Broadband, and Gigabit Fiber!
9 posts Page 1 of 1
by seank » Sat Mar 24, 2018 11:58 am
I'm having a hell of a time getting IP Passthrough working with FTTN and the Arris BGW210 modem. When I set the Allocation Mode to IP Passthrough, the Passthrough Mode dropdown is disabled, making it impossible for me to change it from the default of Manual. I also cannot set a MAC address. This just can't be right.

Sonic's support desk is, surprisingly, very unhelpful, "We're not trained..." ATT support won't talk to me because I'm a Sonic customer.

ATT does have a link https://forums.att.com/t5/AT-T-Internet-Equipment/Strict-NAT-Bridge-Mode-What-is-IP-Passthrough-Can-I-enable-on-my/m-p/5118012/page/2 about setting this up, but as I described, I cannot change the necessary controls.

This is tremendously frustrating.

Anyone else out there using this modem model? I'm beginning to think that there's a defect in this modem. Sigh.
by Bc04 » Wed May 23, 2018 10:33 am
Having exact same issue
by dherr » Wed May 23, 2018 11:06 am
I have FTTN X1 with a Pace 5031nv, so this may not pertain, but I learned that if you want to make any major changes with that router you should start by doing a factory reset. If you don't then it has all manor of strange behaviors.

This model does not let you save the current settings as a backup, so I just keep a simple step by step instruction file telling exactly how to bring the router back to my current config state.
by The Helper » Thu Jun 28, 2018 9:33 am
I had this same problem. The solution is to make sure the DHCP server is still enabled on the BGW210. When the DHCP server is disabled, the field Passthrough Mode is also disabled.

Best thing is to set a separate LAN for the BGW210 and a separate LAN for the other router. For example, I set my BGW210 to 192.168.3.254, with DHCP 192.168.3.1 - 192.168.3.253. On my other router, I left it set at 192.168.2.x. Use any LAN port on the BGW210 to connect to the WAN port on your other router.

This worked perfectly, once I figured out why the field was disabled.
by pauljlucas » Sat Nov 10, 2018 6:18 pm
Best thing is to set a separate LAN for the BGW210 and a separate LAN for the other router. For example, I set my BGW210 to 192.168.3.254, with DHCP 192.168.3.1 - 192.168.3.253. On my other router, I left it set at 192.168.2.x. Use any LAN port on the BGW210 to connect to the WAN port on your other router.


But then that isn't IP Passthrough. I currently have that set-up and my own router is complaining about double NAT. AFAIK, if it were IP passthrough, the publicly routable WAN IP address that comes into the BGW210 would be passed through to one's own router's WAN port so then it would have the original WAN IP address, i.e., it would be as if the BGW210 weren't even there.

When I select IP Passthrough with DHCPS-dynamic, neither the Default Server Internal Address nor the Passthrough Fixed MAC Address fields are editable. If I change it to DHCPS-fixed, then I can enter something into the Passthrough Fixed MAC Address field.

I did try this and it fubar'd my network. I couldn't even access the BGW210's web page any more, so I had to factory reset it.

Question: assuming this did work and the BGW210 were passing everything through to my router (which is 192.168.2.1) and network (192.168.2.x), then how can you access the BGW210's web page? If it's pass-through, then you'd think it wouldn't even have an IP address any more.
by tgregg3100 » Mon Mar 18, 2019 8:11 pm
I see this topic has been quiet for a while, but I'm in the identical scenario - Sonic tells me they don't support passthrough, so I'm trying to get it going on my own. I actually had it working for about 10 minutes, before the ATT BGW210 performed some firmware updates automatically and seemed to wipe the config.

If anyone has gotten passthrough working properly (or even just turning NAT /DHCP off), what settings did you adjust on the BGW210 exactly?
by naltimari » Tue Sep 17, 2019 1:43 am
So I recently got this working. At first I had to set the IP passthrough mode to dynamic because it wouldn't allow me to enter one manually. So I selected my edgerouter 4 via its IP. I noticed if you turn off the DHCP server, it sets to passthrough mode to manual on the last selected device, and it will stay on manual via fixed MAC address.

Next, I had public subnet off, cascaded router enabled, cascaded router address set to 0.0.0.0.

The tricky setting that worked for me, is setting the network address to 99.29.92.136, and the subnet mask to 255.255.255.248. I found these on an ATT user forum. Since my line is ATT leased, i figured it might work. After that, I was able to get my edgerouter 4 working great. I could not get this to work with any other set of IP numbers... but this is how I got IP passthrough to work properly.

I hope this helps someone out there. Good luck.
by naltimari » Tue Sep 17, 2019 11:30 pm
regarding my suggestion -- AT&T has now twice factory reset my gateway. I come home from work, and learn I have no internet. Then I discover the BGW210 is back to it's old IP, and all settings back to factory default.

I'm not sure if AT&T is doing this on purpose, but I can setup everything again and it starts working. It's just annoying... it feels like AT&T is purposely messing with Sonic customers.
by Sonic Guest » Wed Sep 18, 2019 1:39 am
pauljlucas wrote:
Question: assuming this did work and the BGW210 were passing everything through to my router (which is 192.168.2.1) and network (192.168.2.x), then how can you access the BGW210's web page? If it's pass-through, then you'd think it wouldn't even have an IP address any more.

The RG has a rule that allows all packets access to the RG IP. If you don't want other users access you should create some filter rules on your router and not allow others access to the BGW210's subnet, including WiFi.

Setting IP Passthrough was quite easy.
  1. Start with standard config: DHCP enabled w/ 1-day lease, FW enabled, Packet Filter enabled, RG at 192.168.1.254.
  2. Connect your own router's WAN port to a port of the BGW210.
  3. On your router, note its WAN IP. It should be in the 192.168.1.0/24 subnet. Note its MAC address.
  4. Go to RG: Firewall > IP Passthrough
  5. Choose Allocation Mode = Passthrough
  6. Choose Passthrough Mode = DHCPS-fixed
  7. In Passthrough Fixed MAC Address, click Device List drop down and choose the entry with your router's hostname/MAC address from step 3. After this is done, the Manual Entry field will have the MAC address of your router automatically populated.
  8. Click Save
Optionally you can change Passthrough DHCP Lease time; Default Server Internal Address remains uneditable.

Because your router already has a lease in the 192.168.1.0/24 subnet you need to release/renew the WAN interface so it will obtain the true WAN IP. Devices that don't have this capability will need a reboot/power-cycle. After that, your router should have the true WAN IP.

Unfortunately connections will still go through the RG's subnet. The extra hop isn't too much of a problem but if you require a lot of sessions the BGW210's 8192 will be a problem.
9 posts Page 1 of 1

Who is online

In total there are 5 users online :: 0 registered, 0 hidden and 5 guests (based on users active over the past 5 minutes)
Most users ever online was 422 on Sat May 26, 2012 5:28 am

Users browsing this forum: No registered users and 5 guests