New shell server transition

Advanced feature discussion, beta programs and unsupported "Labs" features.
306 posts Page 23 of 31
by goetsch » Fri May 11, 2018 4:05 pm
patty1 wrote:
sh.sonic.net is working for me as of about 2:30 p.m. (The first time I've tried it today.) Are the rest of you getting in to it okay now, too?


I run an hourly cron job; the last error message I got was in the 9:00 am hour, so presumably I got my directory back sometime before 10:00 this morning.
by scott » Tue May 15, 2018 5:03 pm
goetsch wrote:
patty1 wrote:
sh.sonic.net is working for me as of about 2:30 p.m. (The first time I've tried it today.) Are the rest of you getting in to it okay now, too?


I run an hourly cron job; the last error message I got was in the 9:00 am hour, so presumably I got my directory back sometime before 10:00 this morning.


Yes, this was a painful episode brought on by a bit of a version jump in system maintenance. We use rolling updates for CentOS. They jumped to the next point release, which caused much havoc for a couple of days (the 10th and the 11th).

We're working on how to avoid that sort of problem in the future. I'm also going to add more robust monitoring to detect if the shell server isn't behaving itself.

-Scott
by scott » Tue May 15, 2018 5:08 pm
A note on mutt and lynx:

This took a while to figure out, but I think I have an answer. Later versions of mutt won't use lynx interactively if specified to do so in one's ~/.mailcap . To get it to use an interactive entry, you have to select your message with "v" (to view attachments, or a text/html message), then him "m" to force the interactive entry.

I've changed the system /etc/mailcap to do something akin to the "right thing". If any mutt users _don't_ want to use lynx, you can override that in your own ~/.mailcap .

Incidentally, before the system /etc/mailcap it was using xdg-open, which seems to have support for lynx/elinks/links2/w3m/etc, but I'll be danged if I could get that to work.

-Scott
by lr » Wed May 16, 2018 11:37 am
And it's unreachable again:
> ssh lr@sh.sonic.net
ssh_exchange_identification: read: Connection reset by peer

Started about 10 minutes ago.
Linda and Ralph and John; 735 Sunset Ridge Road; Los Gatos, CA 95033; 408-395-1435
by scott » Wed May 16, 2018 12:02 pm
lr wrote:
And it's unreachable again:
> ssh lr@sh.sonic.net
ssh_exchange_identification: read: Connection reset by peer

Started about 10 minutes ago.


Is it still doing it? I'm able to log in okay.

We did have a hiccup with the passwd database for a minute or two, that might have been what happened.

-Scott
p.s. (edit): I saw that your host was in /etc/hosts.deny, which means denyhosts locked you out for some reason. This may be related to the issue above, since the system might not have known who you were when you tried to log in at one point.
by lr » Wed May 16, 2018 12:06 pm
Fixed now. Thank you. Sorry to not reply sooner, I was outside doing a little yard work instead of lunch. BTW, putting things automatically into hosts.deny is a great idea, unless your authentication system is unreliable, in which case it becomes a bad idea. But you knew that.
Linda and Ralph and John; 735 Sunset Ridge Road; Los Gatos, CA 95033; 408-395-1435
by kyezbick » Wed May 16, 2018 1:07 pm
kyezbick wrote:
Still need ncurses installed please.


Wondering if there is a plan to get ncurses running again. Here is the error I get:

Code: Select all

"error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory"


Used bolt.sonic.net pretty regularly for a decade or more without this issue and am hoping it will work for me again :D .

Thanks!
by lr » Wed May 16, 2018 5:37 pm
Regarding libncurses: It's definitely there, look in /usr/lib64/libncurses.so.5. Can you recompile and relink your program quickly? It might be looking for a 32-bit version of the library if it hasn't been recompiled since moving to the new machine.

Just to be clear: I'm not the sysadmin, and I'm not saying that all 32-bit programs need to be recompiled; just seeing whether one hint might get you back on the air faster.
Linda and Ralph and John; 735 Sunset Ridge Road; Los Gatos, CA 95033; 408-395-1435
by kyezbick » Thu May 17, 2018 12:23 pm
Great, I'll try a recompile. Thanks!
by kyezbick » Thu May 17, 2018 12:42 pm
Worked! Thanks for the tip, lr!
306 posts Page 23 of 31

Who is online

In total there are 3 users online :: 0 registered, 0 hidden and 3 guests (based on users active over the past 5 minutes)
Most users ever online was 422 on Sat May 26, 2012 5:28 am

Users browsing this forum: No registered users and 3 guests