Lost connection while on the road ...

Internet access discussion, including Fusion, IP Broadband, and Gigabit Fiber!
5 posts Page 1 of 1
by gizmos » Sun Aug 11, 2019 1:16 pm
I've had Sonic Fusion (aka AT&T Uverse) X2 for years and it's always been great. I run a couple of servers at home that I frequently access remotely over this connection. Even though I theoretically have a dynamic IP from AT&T, in 4 or 5 years the assigned IP has never changed.

Here's the interesting part - I've been on the road for a week, and with two more weeks to go on the road, I've lost all connection to the servers at home. Nothing at home is accessible anymore, EXCEPT the Sonic ATA. Interestingly, the ATA is still registered and indeed I can even phone it. I don't use the SOnic voicemail service and have an answering machine connected directly to the ATA, so I'm pretty sure the call is actually getting thru to the box in my house.

Even more interestingly, one of the servers emails me a status report every hour and from that it would appear that the connection dropped at exactly midnight PDT last night. That could be a coincidence, but the timing is suggestive. If I was home I'd look at it and try to figure out what was going on, but I'm thousands of miles away.

Does anybody have any ideas or suggestions? I tried calling Sonic support, but other than confirming that my ATA was indeed still online, they couldn't help.

Did AT&T roll out any firmware updates for the NVG589 recently? I'm wondering if AT&T updated my modem and it's broken something.

Or as anybody had AT&T change their "dynamic" IP without warning ?

by js9erfan » Sun Aug 11, 2019 5:51 pm
How are you connecting to the servers and over what port? Even with a dynamic IP change which is common, your server should still be able to send outbound email/traffic... That said, if your router did receive a firmware update which reset it in someway to default and you had set static LAN IP's for those servers in a subnet that's not default on the router for example, I could see how this could happen. Or, perhaps there was a power outage and the servers aren't connected to a UPS, the UPS battery expired or WOL/restore on AC isn't enabled then maybe they're off. I would also check that traffic is not being filtered or blocked in your current location preventing you from accessing your servers. Obviously these are just assumptions since you didn't provide much detail of your network.

In the end if your WAN IP simply changed then I would consider using a free DDNS service to help prevent this. Good luck.
by gizmos » Mon Aug 12, 2019 5:39 am
>How are you connecting to the servers and over what port?

VPN, and also ssh (both using non-standard port numbers)....

>Even with a dynamic IP change ... be able to send outbound email/traffic...

Agreed. That failure puzzles me too, but without access to the machines I can only speculate.

>... you didn't provide much detail of your network.

The NVG589 (the AT&T supplied Uverse X2 modem) is essentially configured as a bridge - this box doesn't have a literal bridge mode, but you can use its DMZ to the same effect. The 100baseT side of the NVG589 goes directly to a Cisco RV router, which is configured to handle all the inbound/outbound rules, NAT, port translations, etc. The RV also terminates VPN connections from outside. Everything else is on the "intranet" internal side of the router.

There is a battery UPS on the NVG589, Cisco, one primary server and other essential network equipment, that's good for 10-12 hours.

In retrospect, DDNS would have been a good idea, but I never needed it before :(
by gizmos » Mon Aug 12, 2019 6:19 am
P.S. I checked my records, and FWIW I've had Fusion and the NVG589 four years now. In that time I've never seen AT&T change the "dynamic" IP. Twice I've seen AT&T force firmware updates on the NVG589 that's broken stuff. They may have updated it more often than that, but if it didn't break anything then I wouldn't notice...
by js9erfan » Tue Aug 13, 2019 7:11 am
Have you checked your IP and VPN/SSH port status with Nmap? I have a similar setup using a pfSense box as my VPN server and gateway but fortunately, I haven't seen an ATT firmware update break or even reset this Pace 5268 modem (FTTN user for several years now).

Still curious that your ATA is communicating outbound traffic but your servers aren't... One would think if a firmware update broke your modem's config neither would be communicating unless perhaps your ATA is connected directly to the modem. Impossible to say in your case other than unfortunate timing obviously.
5 posts Page 1 of 1

Who is online

In total there are 10 users online :: 1 registered, 0 hidden and 9 guests (based on users active over the past 5 minutes)
Most users ever online was 700 on Thu Jun 18, 2020 12:00 pm

Users browsing this forum: Bing [Bot] and 9 guests