Issues with IPv6 on Fusion Fiber in the SF Mission neighborhood

Advanced feature discussion, beta programs and unsupported "Labs" features.
2 posts Page 1 of 1
by richardxia » Mon May 27, 2024 2:10 pm
I had originally emailed support (ticket #7497846) about this, but was referred to this forum.

I am located in the San Francisco Mission neighborhood, and I have the Fusion Fiber 1 Gbps plan, using the SmartRG SR516ac router that Sonic has provided. I think native IPv6 was rolled out to me sometime last year, but had disabled it shortly after the rollout because it wasn't working properly, and it was actively degrading my service. My guess as to the performance degradation was that it was causing all initial requests to websites to feel very slow due to the Happy Eyeballs algorithm always attempting to connect via IPv6 first, but always failing and falling back to IPv4, which basically incurs a latency penalty for all initial requests to new domains.

Flash forward about a year, I recently decided to reenable IPv6 on my router to see if anything had improved, but it doesn't look like the situation has changed. I've done more research and investigation of IPv6 this time around, but I am definitely not an expert on it or on network engineering in general, so apologies in advance if I am misunderstanding how things should work. When I say "IPv6 is not working", I specifically mean that https://test-ipv6.com/ reports that IPv6 I don't have an IPv6 address and that ping6 2001:4860:4860::8888 hangs (not fails, but hangs indefinitely).

Here's everything that I know about my current setup as I have been debugging this.

Looking at the SmartRG's settings, under "Advanced Setup -> WAN Service", I have "Obtain an IPv6 automatically" selected along with "Dhcpv6 Prefix Delegation (IAPD)" checked, as opposed to "Dhcpv6 Address Assignment (IANA)". Is this the correct setting? It looks like the SmartRG is receiving an IPv6 address with a /64 prefix on its WAN interface, at least as reported on the admin site on the "Device Info -> WAN" page. Is the /64 prefix correct here? I've seen other forum posts saying that the initial Sonic IPv6 rollout gave people /64s, but newer ones have /56s. I'm not sure how to even attempt to request a /56, since the SmartRG interface doesn't have any field for setting a requested prefix size, at least without specifying a complete static address along with prefix.

I'm not sure if the the /64 prefix on the WAN interface matters, so I've continued to debug the rest of the stack. It looks like my devices (MacBooks + Linux desktop + Android phone) are successfully receiving IPv6 addresses when connected to the router. Aside from the one link-local address (ones starting with fe80) on each device, all the other addresses appear to have a prefix for global unicast addresses. The prefixes match the prefix on the router's WAN interface (starting with 2001, and matching the next 3 hextets), so I think everything is correct here, but it'd be good to get confirmation about this.

When I examine the routing tables for my devices, they show the default route is the link-local address of the SmartRG, which starts with fe80 and ends with the last 64 bits matching the EUI-64 generated from the SmartRG's MAC address, though the last bit is flipped (maybe the MAC address of the LAN interface is just one bit away from the MAC address of the WAN interface?). When I examine the routing table for the SmartRG itself (admin site's "Device Info -> Route" page), it looks like the default route is another link-local address, which I assume points to something upstream of me in the Sonic network. I can also see routes for the global addresses of my devices, but only some and not all of them. I assume it'll only show the addresses that it has actually seen from my devices?

I am able to ping my other devices within the LAN using their global IPv6 address. However, I can't ping external addresses, such as Google's IPv6 DNS servers (2001:4860:4860::8888).

The really curious thing is that if I attempt to ping the router from devices using the router's global address on the WAN interface, it'll actually temporarily make IPv6 work for requests to external hosts on the device I sent the ping from, since both https://test-ipv6.com/ and pinging Google's DNS server will work. This only works temporarily, and after a few minutes, it stops working again unless I keep the ping running indefinitely in the background. For what it's worth, the very first ping response from the router feels like it takes longer than the others. The ping command reports only 1-3 ms for that first ping response, but I can feel a lag between when I send the ping request and getting that first response. If I run the ping command again within a few minutes, while IPv6 is still working, then the first ping response returns immediately, without the lag.

I'm not really sure how to debug further from here. I feel like there is some internal state in the SmartRG that gets "fixed" when I ping the SmartRG by its global address, but I'm not really sure what it is. I'd really appreciate it if someone could provide some pointers for what else I should look at or what settings to configure on the SmartRG admin panel.
by spencerw » Thu May 30, 2024 1:43 pm
I'm sorry our support rep led you astray here, the Smart RG can't actually do IPv6. It's a little confusing because you can set it up and it looks like it should work but simply doesn't. I've submitted a training event for that rep so they can get up to speed on this stuff. To resolve this, we will need to swap your Smartrg out for an eero. I will follow up with you in the original ticket to get that process started. I apologize for the confusion.
Spencer W.
Community and Escalations Specialist
Sonic
2 posts Page 1 of 1

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 999 on Mon May 10, 2021 1:02 am

Users browsing this forum: No registered users and 1 guest