Can't update Wordpress themes

Web hosting discussion, programming, and shared and dedicated servers.
3 posts Page 1 of 1
by patty1 » Thu May 09, 2019 7:56 am
Yesterday I got an alert from Wordpress that the software itself and several themes needed to be updated. I got WP updated, but when I tried to update the themes, nothing happened. I've since tried to update them individually, and they keep stalling at this point:
The update process is starting. This process may take a while on some hosts, so please be patient.
Updating Theme Twenty Nineteen (1/1)

I left one updated running overnight and nothing else happened. My browser tab indicated loading for several seconds, then stopped as though it had finished. I looked at my WP directory just now and confirmed that none of the themes have been updated recently:

drwxr-xr-x. 1 patty1 user 4096 Feb 26 20:05 twentyfifteen
drwxr-xr-x. 1 patty1 user 4096 Feb 26 20:05 twentynineteen
drwxr-xr-x. 1 patty1 user 4096 Feb 26 20:05 twentyseventeen
drwxr-xr-x. 1 patty1 user 4096 Feb 26 20:05 twentysixteen

One of the themes is my active one; I'm afraid to try updating that one until I sort out this problem.

Any ideas how to get the updates to take?
by joemuller » Thu May 09, 2019 4:24 pm
Hi Patty,

I've done some quick digging around, and it looks like there are some bugs in the latest (5.2) release of Wordpress. The official Wordpress bug entry is here. I'm seeing similar errors for one of your sites:

Code: Select all

PHP Fatal error:  Maximum execution time of 30 seconds exceeded in .../ on line 55

The current workaround is to temporarily increase the timeout for PHP. You can do this by adding the following to the .user.ini file for your site:

Code: Select all

max_execution_time = 60

Ideally you should be able to remove that line once everything is updated.

-- Joe M
Sonic System Operations
I'm a proud employee of! :-)
by patty1 » Thu May 09, 2019 4:47 pm
Hi, Joe. Thank you very much for that research.

I added the following lines to .user.ini:

Code: Select all

; temporary fix for update timeout problem in WP5.2
 max_execution_time = 60

Still no luck, so I increased the timeout to 120 seconds, but that didn't work, either. Looks like I'll have to wait for 5.2.1. From the thread you linked to, it appears that people are now testing that version, so hopefully it will be available to users soon. Otherwise, I'll have to downgrade back to 5.1, which is more complicated than clicking an Upgrade button!
3 posts Page 1 of 1

Who is online

In total there are 8 users online :: 1 registered, 0 hidden and 7 guests (based on users active over the past 5 minutes)
Most users ever online was 999 on Mon May 10, 2021 1:02 am

Users browsing this forum: Bing [Bot] and 7 guests