PHP update needed

Web hosting discussion, programming, and shared and dedicated servers.
59 posts Page 6 of 6
by duckseed » Sun Jul 26, 2020 6:10 am
I need help updating my php to at least 5.6 for Wordpress.
I know I have to create a text file with the 2 lines of code in it. (I pasted the lines into a Word doc and then saved it as a Plain text file - correct?).
I don't know how to access the root directory and then where I drop in the text file.
Can I access the directory in the Wordpress dashboard?
Can anyone tell me the steps I need to take?
Ele
by westcot » Mon Nov 09, 2020 11:36 pm
I have read through all these answers and questions and cannot figure out how to update my site to PHP 7. I cannot figure out where this htaccess file so I can update it. Can anyone explain this even more simply and not just post a link that don't seem to help me either. is there a way I can find it on my wordpress site? Thank you for any help
by joemuller » Tue Nov 10, 2020 9:59 am
westcot wrote:
I have read through all these answers and questions and cannot figure out how to update my site to PHP 7. I cannot figure out where this htaccess file so I can update it. Can anyone explain this even more simply and not just post a link that don't seem to help me either. is there a way I can find it on my wordpress site? Thank you for any help


Here's a way to switch your site to PHP 7 by editing the htaccess file through Wordpress.

1.) Install the WP Htaccess Editor plugin.

Image


2.) Enable the plugin.

Image


3.) Click 'WP Htaccess Editor' under the 'Settings' menu on the left-hand side.

Image


4.) Find the line that begins with 'Action php-cgi' and change the it to be this:

Code: Select all

Action php-cgi /cgi-bin/php7


Image


5.) Click 'Save Changes'.

Assuming everything goes well, you should be able to log out of the Admin panel and view your site normally.

-- Joe M.
Sonic System Operations
I'm a proud employee of Sonic.net! :-)
by westcot » Tue Nov 10, 2020 12:19 pm
Thank you so so much for making it so very simple. I did it! I did the test before saving and it was good to go. But, when I saved changes, I got the big giant X that my site will not be accessible and had to restore the original php. I'm bummed that I cannot seem to get my site to PHP 7. Do you have any suggestions why this is not working? I've updated all my plug ins and my layer slider says it's the latest version.
by ankh » Fri Nov 13, 2020 11:49 pm
If I were to post a request offering to hire someone to fix this for me, what would be a fair price to do the job? Could Sonic vet people who could be relied on to be hired to do this kind of help?

I'm old, and I've gootten increasingly tired of messing with this kind of stuff.

I don't have actively used web pages, just a couple set up in advance for possible future use.
by ggdeb » Wed Mar 10, 2021 3:10 pm
Hello,
I have two domain names, Snoopy's Writers and Georgette G. deBlois.
My Chromebook keeps telling me I need to update to Word Press 5.7. I tried following the steps to make that happen. The language is way above me and confusing. I'm a little old 80+-year-old lady in tennis shoes. When in Word Press I keep getting a message that I need to update my PHP v. 5.3.29 to 5.6,20 or higher in order to upgrade to 5.7
I tried to do it but I don't understand the many steps involved. Please, can someone at Sonic.net have a look and take care of it.
Many Thanks,
Georgette G. deBlois
ggdeb@sonic.net
by joemuller » Fri Mar 12, 2021 5:58 pm
Hi Georgette,

I've made the necessary change for both of your websites to have PHP 5.6, which should let you safely update Wordpress.

-- Joe M
Sonic System Operations
I'm a proud employee of Sonic.net! :-)
by tikvah » Mon Mar 22, 2021 8:07 pm
Mine were updated already but then one was either missed or has now failed. The others update Wordpress automatically, as they should. But this one fails because PHP is out of date.

I wrote Sonic support in January asking for it to be resolved and got back this response:
"We are unable to update this for you, as this is content related. We cannot interfere with the content of your site."

:roll:

The site is ehnca.org. Can you please help?

Thanks!

Screen Shot 2021-03-22 at 8.06.21 PM.png
Screen Shot 2021-03-22 at 8.06.21 PM.png (48.77 KiB) Viewed 1528 times
by tikvah » Sat Mar 27, 2021 5:01 pm
Thanks for fixing ehnca.org. But now I can't get into another site. I checked my sites and this is the only one not loading normally. When I tried to go to a specific link, it went to Google Play. When I try to go to my homepage, I get this.

Seriously, I'm *this close* to closing all my Sonic.net accounts. They say "not secure" because I can't buy the https certs. They require manual updates of PHP. They go down several times a week (for a few minutes or sometimes hours). And when I ask support for help, they tell me they don't have anything to do with websites or my "content."

And then I get stuff like this. This is not the first time it happened but it's the first time I couldn't get into my admin panel.

Thank you for your help.

Screen Shot 2021-03-27 at 4.55.14 PM.png
Screen Shot 2021-03-27 at 4.55.14 PM.png (28.42 KiB) Viewed 1487 times
59 posts Page 6 of 6

Who is online

In total there are 2 users online :: 0 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 999 on Mon May 10, 2021 1:02 am

Users browsing this forum: No registered users and 2 guests