swrast_dri.so missing?

Web hosting discussion, programming, and shared and dedicated servers.
2 posts Page 1 of 1
by casner » Wed Jan 02, 2019 2:36 pm
I connected to sh.sonic.net using ssh and X11 forwarding. When I started emacs, which creates a new X11 window, there were two error messages in the terminal window:

sh.sonic.net3> libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

I've run emacs a bunch of times since the server transition without seeing this error. The last time was probably a few weeks ago. In this instance the emacs window was still created and is functional, so it must have backed off to a different method.

Have the libraries changed recently?

Steve
by casner » Wed Jan 02, 2019 3:07 pm
Then later emacs crashed:

sh.sonic.net3> X protocol error: BadLength (poly request too large or internal Xlib length error) on protocol request 141
When compiled with GTK, Emacs cannot recover from X disconnects.
This is a GTK bug: https://bugzilla.gnome.org/show_bug.cgi?id=85715
For details, see etc/PROBLEMS.

(emacs:19842): GLib-WARNING **: 15:03:21.925: g_main_context_prepare() called recursively from within a source's check() or prepare() member.

(emacs:19842): GLib-WARNING **: 15:03:21.925: g_main_context_check() called recursively from within a source's check() or prepare() member.

Backtrace:
emacs[0x4f8623]
emacs[0x4ddc51]
emacs[0x4f8663]
emacs[0x4b2b4b]
emacs[0x4b4dbc]
emacs[0x4b4e1d]
/lib64/libX11.so.6(_XError+0x12b)[0x7f70a83fee8b]
/lib64/libX11.so.6(+0x41ee7)[0x7f70a83fbee7]
/lib64/libX11.so.6(+0x41fa5)[0x7f70a83fbfa5]
/lib64/libX11.so.6(_XEventsQueued+0x55)[0x7f70a83fc8b5]
/lib64/libX11.so.6(XPending+0x4d)[0x7f70a83ee3ed]
...
2 posts Page 1 of 1

Who is online

In total there are 5 users online :: 0 registered, 0 hidden and 5 guests (based on users active over the past 5 minutes)
Most users ever online was 422 on Sat May 26, 2012 5:28 am

Users browsing this forum: No registered users and 5 guests