Hosting website through wampserver, port forwarding problems

Web hosting discussion, programming, and shared and dedicated servers.
4 posts Page 1 of 1
by bzzhan » Sun Sep 02, 2018 10:01 pm
I have had a webserver that has been hosting my website for a long time, and now that I have switched to sonic, I can't seem to get port forwarding to work. I have been looking at NAT, under advanced setup. I tried adding a virtual server with interface ipoe_eth4/eth4.1, and all the port things set to 80. I get a message that port 80 is being used but still sets the ports to 80.

The website is viewable using the private ip, but using the public ip gives me the message: You don't have permission to access /prime-home/control-panel/login on this server.

I am using a SMART/RG SR515ac, gigabit fiber.

Does anyone know what to do to get this running?
by manno » Fri Oct 12, 2018 3:20 pm
I tried the same thing - setting up a webserver (port 80) and SSH (port 22) without success. I used the NAT, --> Virtual Server section, added the ports like this. I matched up my server IP (show below) and tried both. I did discover that when you ssh over the internet, you get the router's ssh (which I was able to login to using admin/pw). So, the device seems to want to us port 22. So, I tried setting up ssh on port 2222. No luck. Then Management, --> Access Control: I made all was enabled, changed the ports to match, etc. Still no luck.

Has anyone figured this out?

server Name External Port Start External Port End Protocol Internal Port Start Internal Port End Server IP Address WAN Interface Remove
Secure Shell Server (SSH) 22 22 TCP 22 22 atm0.1
Web Server (HTTP) 80 80 TCP 80 80 atm0.1
by manno » Fri Oct 12, 2018 3:25 pm
I am having the same problem, same error message in trying to get an HTTP port 80 Server accessible. I tried using Advanced, --> NAT, --> Virtual Servers. I configured port 80 and have a webserver internally (at my house, attached via ethernet) that's up and running, working - and matched the IP address to the Virtual server, etc.

Message in my browser:
You don't have permission to access /prime-home/control-panel/login on this server.
Apache/2.2.29 (Amazon) Server at Port 443
by takato » Tue Nov 13, 2018 9:21 pm
I got WEB hosting to work with my new Sonic gigbit service with a Smart/RG SR515ac modem.
Here are my current modem settings:

> Management
>> Access Control
<all set to off>
# apparently these settings control the access to the modem, e.g., if HTTP is on than all port 80 packets are filtered to the modem, i.e., no WAN packets get to the LAN

> Advanced Setup
>> LAN
Static IP Lease List
MAC Address IP Address
# it seems necessary to associate the WEB host's MAC address to a Static IP referenced in Virtual Server setting

>> NAT
>>> Virtual Servers
Server Name External Port Start External Port End Protocol Internal Port Start Internal Port End Server IP Address WAN Interface Remove
icstool 8081 8082 TCP/UDP 8081 8082 eth4.1
# Virtual Servers settings seem to be necessary where the ports, IP Address, and WAN interface(found in Device Info under Default Gateway) are specified.

>>> Port Triggering
icstool TCP/UDP 80 80 TCP/UDP 80 80
icstool TCP/UDP 8081 8082 TCP/UDP 8081 8082
# I have set Port Triggering as above. The inline comments seem to indicate that only this setting is sufficient to pass WAN packets onto the LAN but my experience differs.

Of course, for WEB hosting I have /etc/apache2/ports.conf set to Listen for the appropriate Port.
4 posts Page 1 of 1

Who is online

In total there are 4 users online :: 0 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 422 on Sat May 26, 2012 5:28 am

Users browsing this forum: No registered users and 4 guests