updating PHP

Web hosting discussion, programming, and shared and dedicated servers.
2 posts Page 1 of 1
by jonas » Fri Aug 17, 2018 2:01 pm
Sonic has locked my website "for abuse". I hired Sucuri to investigate the problem. They told me there are no malware infections, but that the PHP needs to be updated to at least 5.2.4. They recommended I contact my hosting provider (Sonic). Sonic says they are not able to update the PHP because they don't know how the website was set up. I don't know how the website was set up. The woman who set it up eight years ago lost her house in the fires and is not available. I'm not a technical person and don't have time to research this. Can anyone recommend a webmaster (or really anyone) who I can hire to fix this? Thank you.
by joemuller » Fri Aug 17, 2018 7:19 pm
Hi,

If the website in question is hosted here at Sonic, you can tell the server which version of PHP to use by changing what's known as the 'htaccess file' (the filename is '.htaccess') in the main folder of the site. You'll need to make sure the following is at the top of that file:

Code: Select all

AddHandler php-cgi .php
Action php-cgi /cgi-bin/php56


We have a support page over here that details how to change which version PHP the site is using.

-- Joe M.
Sonic System Operations
I'm a proud employee of Sonic.net! :-)
2 posts Page 1 of 1

Who is online

In total there are 5 users online :: 0 registered, 0 hidden and 5 guests (based on users active over the past 5 minutes)
Most users ever online was 999 on Mon May 10, 2021 1:02 am

Users browsing this forum: No registered users and 5 guests