Internal 500 error

Web hosting discussion, programming, and shared and dedicated servers.
8 posts Page 1 of 1
by downtown » Sun Jan 07, 2018 9:43 am

I tried renaming all the plugins and it didn't work. Can anyone help with this? The website is

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Apache/1.3.41 Server at Port 80

Thank you!!!
Steve Brown
by robert_s » Sun Jan 07, 2018 4:56 pm
Error is /.htaccess: Header takes two or three arguments, an action, header and value

Best I could figure out is that commenting out Header append Vary User-Agent env=!dont-vary in your .htaccess resolves the issue but there are other issues.

Maybe someone with more WordPress experience can comment.
Robert S.
Proud Sonic Employee
by downtown » Mon Jan 08, 2018 9:12 am
If I disable the .htaccess it still doesn't work
by robert_s » Tue Jan 09, 2018 7:52 am
In addition to the .htaccess problem, one of the plugins was not compatible with Apache 1.3.
Robert S.
Proud Sonic Employee
by downtown » Thu Jan 11, 2018 8:23 am

I commented out the .htaccess string, nothing happened. I renamed ALL the plugins, nothing happened. It still reads Internal Server Error 500.

My theme developer says it's an ISP issue. We need more help please!!!!

"Hi Mikealwood88,

I am sorry but it's server error
You have to contact to your hosting provider regarding the server error.

by drew.phillips » Thu Jan 11, 2018 5:35 pm
Hi downtown,

I took a look at the site and corrected the .htaccess file but there are still other issues.

It looks like the "develop" directory and the primary site in the root folder have crossed over. The w3-total-cache plugin wrote to the .htaccess file in your main directory and added entries that are not compatible with our version of Apache. They are all the AddOutputfFilterByType entries.

After I commented those out, the site no longer returns a 500 error, but is failing to load. This is due to:

PHP Fatal error: Call to undefined function apply_filters() in /nfs/www/WWW_pages/yourusername/ on line 316

I checked that file against the latest version of WordPress and they do not match up despite wp-includes/version.php showing it is 4.9.1 (the latest). The error stemming from that file would be fixed by having the correct version of that file.

I'd suggest uploading all files from the latest WordPress package over your existing site files to fix any remaining issues.

If you re-enable the w3-total-cache plugin again, it will break the .htaccess again so I'd shy away from that plugin.

My conclusion is that two things happened, perhaps a mixup working on the develop site vs the live site, and compatibility issues with the w3-total-cache plugin that cause the original 500 error.

Uploading the latest WordPress files into the root should get the site back up and running again.
Drew Phillips
Programmer / System Operations,
by downtown » Thu Jan 11, 2018 5:48 pm
I replaced everything except the content folder. this is the error I am getting now

Parse error: syntax error, unexpected end of file in /nfs/www/WWW_pages/downtown/ on line 127
by drew.phillips » Thu Jan 11, 2018 5:51 pm
A quick peek at this file shows that it looks like the end got cut off. It should be around 147 lines and is missing everything after that point.
Drew Phillips
Programmer / System Operations,
8 posts Page 1 of 1

Who is online

In total there are 3 users online :: 1 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 700 on Thu Jun 18, 2020 12:00 pm

Users browsing this forum: Bing [Bot] and 2 guests