GD Library for image processing

Web hosting discussion, programming, and shared and dedicated servers.
4 posts Page 1 of 1
by esca » Wed Apr 21, 2021 10:14 am
Our NextGen Gallery WordPress plugin stopped generating thumbnail images upon image upload. Troubleshooting this plugin shows it needs GD Library enabled and MySQL 5.6. Sonic is still running MySQL 5.5. But I wanted to confirm GD Library was installed and/or up-to-date. Called tech support and they said they couldn't install and they also confirmed they took away shell access for users so I can't install myself. Anyone have any suggestions?

Have already enabled/disables the plugin. Turned off other plugins. And cleared image cache within the plugin itself. Updated PHP to 7.4.3 and enabled mod_rewrite Apache module via .htaccess. Confirmed /wp-content directory is set to 755 permissions.
by joemuller » Mon Apr 26, 2021 6:21 pm
Hi,

The GD Library should be available under PHP 7. As for the MySQL version, we currently have the latest patched 5.5 release installed, but will likely upgrade to at least MySQL 5.6 in the future as various hardware and software upgrades are scheduled. (Wordpress itself will run fine on MySQL 5.5, they just recommend 5.6 for better performance in some cases.)

Concerning shell access, you should still be able to login to shell.sonic.net over SSH using your sonic username and password. This will allow you access to your web hosting files (under the public_html folder) if you prefer to work with them through a shell environment. You won't be able to add PHP libraries, but you can turn on/off PHP features through the use of a .user.ini file.

-- Joe M
Sonic System Operations
I'm a proud employee of Sonic.net! :-)
by esca » Tue May 04, 2021 3:44 pm
What location do i place the .user.ini file?

Message I am receiving from WordPress when uploading images is:
Post-processing of the image failed likely because the server is busy or does not have enough resources. Uploading a smaller image may help. Suggested maximum size is 2500 pixels.

This happens with images that at 100kb and under 1000x1000 pixels. No special characters in the file names.
by joemuller » Tue May 04, 2021 3:59 pm
You'll want to place the .user.ini file in the same directory/folder as your .htaccess file -- after that, you can add lines to it the same as you would to php.ini, and they should in most cases override the default values.

-- Joe M
Sonic System Operations
I'm a proud employee of Sonic.net! :-)
4 posts Page 1 of 1

Who is online

In total there are 5 users online :: 1 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 999 on Mon May 10, 2021 1:02 am

Users browsing this forum: Google [Bot] and 4 guests