Trouble setting up port forwarding for a dedicated game server

Web hosting discussion, programming, and shared and dedicated servers.
7 posts Page 1 of 1
by thehumanbrian » Fri Mar 26, 2021 2:32 pm
Hello party people,

I'm attempting to set up a dedicated server for a multiplayer game hosted on my PC. I've set up port forwarding, packet filters, and allocated my PC's IP on my BGW210 modem and whitelisted the game server through my windows firewall, but testing the open port through websites like canyouseeme.org results in the port coming back as closed or "connection refused."

Any ideas why that might be? This is my first time trying to set up port forwarding so it's entirely possible I eff'd up some part of the process.
by thehumanbrian » Thu Apr 01, 2021 9:50 am
If no one has any ideas, do you know a better place I might look for answers? I've tried calling Sonic customer support and they walked me through setup, but sent me here when that didn't work.
by briancw » Fri Apr 02, 2021 3:08 pm
Hello fellow Brian,

So, this is more or less unsupported and I cannot guarantee if the link I am sending will work, but it is to the place you want to be. That being said, https://portforward.com/arris/bgw210-700/ looks to get you where you need to be. Which game are you making a server for? I can see if I can suss out any specifics.

Are you using the AT&T router alone or do you have your own router connected behind the AT&T one?

Additionally, it is sometimes a weird thing about documentation that they like to say UDP or TCP, some of us how found success in some cases by opening the numbered ports on both UDP and TCP
Brian W
Community & Escalations Specialist
Sonic
by ngufra » Mon Apr 05, 2021 10:08 am
To do this you would typically need the following steps:
-find out the mac address of the server you are using
-in router admin panel, make sure the router will always assign the same local ip to your server (by its mac address) You may need to specify an ip outide the range it uses for automatic ip allocations. if you you will have to renew the ip on this server so it get the new ip (or just reboot it)
-in port forwarding select tcp or udp or both and the outside (public) port or port range, enter the ip of your server, and the port or port range on that server (can be same or different from public port)
-you may need to click somewhere to apply the changes.

Then test. you can use your phone, disable wifi so it uses data. try to hit the public ip sonic has assigned you on one of the ports and the packets should be routed to your server.

You may also want to register to a dynamic dns service so you don't have to remember the ip sonic assigns you that changes unless you have a static ip (which is not available on sonic fiber anyway) . You will need to run a small program on one of your computers to update the ip for your host name. noip.com works well and is free if you are willing to confirm you still want to use it manually every month.
by thehumanbrian » Mon Apr 05, 2021 2:39 pm
Hey gang,

Thanks so much for getting back to me!

The game I'm trying to host is Valheim, through Steam.

I went through the instructions at portforward.com and did what I could to verify the settings are right within the router, but I'm not seeing any positive change. I even found an article specifically for hosting Valheim on Steam on the same website and added a bunch more ports to be forwarded to my machine, but that didn't help either.

We do have a Google Wifi connected to the AT&T router, but the PC in question is connected directly to the router via ethernet cable, and its internal IP is static, set to 192.168.1.100. External IP hasn't changed since I've been looking at this either, if that matters.

Again I've made sure that the Windows Firewall has rules set for Valheim and the dedicated server to allow traffic on all ports.

I've also attached a couple screen shots of the ATT router settings I've set up. Mainframe is my device (its name is in reference to ReBoot) so you can see if I fudged something up somewhere.

I've also just run tests all all the ports shown forwarded in the screen shots on canyouseeme.org and only one of them came back as "Success": 27036. All the others either came back as "Connection refused" or "Connection timed out"

Attachments

by briancw » Mon Apr 05, 2021 3:54 pm
Alrighty, bummer that first fix didn't work.

I think we might need to set up IP Passthrough based on what you are saying.
Check this guide out: https://help.sonic.com/hc/en-us/article ... rty-router

It will show you how to set up IP Passthrough. I found someone in the Valheim subreddit claiming they solved their hosting issue the same way. https://old.reddit.com/r/valheim/commen ... _with_att/

That all tracks with how we usually have to set up these connections when using a 3rd party router.
Brian W
Community & Escalations Specialist
Sonic
by ngufra » Mon Apr 05, 2021 6:14 pm
The rules sound ok.
Try to just turn off the firewall altogether to ensure it's not what is causing problem.
7 posts Page 1 of 1

Who is online

In total there are 4 users online :: 0 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 999 on Mon May 10, 2021 1:02 am

Users browsing this forum: No registered users and 4 guests