WordPress Download file size limit is 2 MB??

Web hosting discussion, programming, and shared and dedicated servers.
8 posts Page 1 of 1
by tpeterson » Wed Jul 15, 2020 1:09 pm
Today when I went to add a download to my site I found that WP was saying that the maximum file size is 2 MB. Huh? When did this change? That's a ridiculous limitation! How do I change that limit?
by joemuller » Fri Jul 17, 2020 12:33 pm
You're right, that is ridiculously small -- I'll see if we can get the default setting put to something more reasonable.

It looks like someone already fixed the issue for you, but for reference, you can add something like the following to the .htaccess file in the main folder for your website:

Code: Select all

php_value upload_max_filesize 64M
php_value post_max_size 64M


Those raise the limits for uploads and POSTs (form submissions) to 64MB each, which should be good enough for most sites.

-- Joe M.
Sonic System Operations
I'm a proud employee of Sonic.net! :-)
by tpeterson » Fri Jul 17, 2020 1:16 pm
Thanks, Joe, for the response. I actually tried changing the .htaccess file after finding that advice via Google, but it didn't seem to work for me. So then I installed "WP Download Manager" plugin and (after disabling the "Simple Download Manager" plugin that I had been using) I enabled WPDM's "chunk mode" and that fixed the problem for me.
by joemuller » Fri Jul 31, 2020 3:14 pm
A quick update:

The default (no need to change anything in .htaccess) upload size limit is now 50 MB for PHP 7.

-- Joe M
Sonic System Operations
I'm a proud employee of Sonic.net! :-)
by tpeterson » Fri Jul 31, 2020 3:40 pm
Thanks.
by tpeterson » Thu Aug 06, 2020 4:20 pm
Joe, I really appreciate your efforts on our behalf. However, I now find that WP using the Simple Download Monitor plugin, which I now seem trapped into using if I'm not going to rewrite my entire site, has an upload file-size limit of 8 MB instead of the previous 2 MB. Still not very generous and far short of the 50 MB that you thought you'd established.
by joemuller » Thu Aug 13, 2020 1:13 pm
Looks like I missed a setting - the post_max_size setting has now been adjusted to 50M as well. Chances are your plugin was trying to upload chunks bigger than the old setting of 8M, which was failing - that should be fixed now.

-- Joe M
I'm a proud employee of Sonic.net! :-)
by tpeterson » Thu Aug 13, 2020 2:19 pm
Yay! Now WP says "Maximum upload file size: 50 MB." Thanks!!
8 posts Page 1 of 1

Who is online

In total there are 4 users online :: 1 registered, 0 hidden and 3 guests (based on users active over the past 5 minutes)
Most users ever online was 999 on Mon May 10, 2021 1:02 am

Users browsing this forum: Bing [Bot] and 3 guests