Page 1 of 1

Trouble using Quad9, bad traceroute from Sonic

Posted: Thu Feb 28, 2019 8:44 am
by yuriw
Anybody is seeing problems with Quad9 (9.9.9.9)?

My traceroute i extremely slow :

traceroute 9.9.9.9
traceroute to 9.9.9.9 (9.9.9.9), 64 hops max, 40 byte packets
1 lo0.bras1.snfcca14.sonic.net (50.0.79.96) 1.063 ms 1.147 ms 0.356 ms
2 0.ae10.cr2.colaca01.sonic.net (142.254.59.149) 12.176 ms 21.395 ms 22.003 ms
3 0.ae0.cr3.colaca01.sonic.net (198.27.244.130) 200.784 ms 177.117 ms 214.054 ms
4 0.ae0.cr2.lsatca11.sonic.net (50.0.79.174) 17.951 ms 21.650 ms 21.570 ms
5 50.ae4.gw.pao1.sonic.net (50.0.2.5) 1.314 ms 1.840 ms 2.210 ms
6 206.41.106.52 (206.41.106.52) 4.474 ms 3.695 ms 4.371 ms
7 206.41.106.52 (206.41.106.52) 3.914 ms !X * *
8 * 206.41.106.52 (206.41.106.52) 4.244 ms !X *
9 206.41.106.52 (206.41.106.52) 4.519 ms !X * *
10 * 206.41.106.52 (206.41.106.52) 4.557 ms !X *
11 206.41.106.52 (206.41.106.52) 4.388 ms !X * 4.451 ms !X

Is Sonic aware of this ?

Re: Trouble using Quad9, bad traceroute from Sonic

Posted: Sun Mar 03, 2019 11:32 am
by bubba198
Same here:

boyan@boyan-desktop:~$ traceroute 9.9.9.9
traceroute to 9.9.9.9 (9.9.9.9), 30 hops max, 60 byte packets
 1  lo0.bras1.snfcca14.sonic.net (50.0.79.96)  3.217 ms  3.249 ms  3.234 ms
 2  0.ae10.cr2.colaca01.sonic.net (142.254.59.149)  242.324 ms  243.049 ms  243.072 ms
 3  0.ae0.cr3.colaca01.sonic.net (198.27.244.130)  136.950 ms  137.031 ms  137.022 ms
 4  * * *
 5  50.ae4.gw.pao1.sonic.net (50.0.2.5)  5.277 ms  5.839 ms  5.871 ms
 6  206.41.106.52 (206.41.106.52)  7.143 ms  4.230 ms  4.262 ms
 7  206.41.106.52 (206.41.106.52)  5.605 ms !X * *
boyan@boyan-desktop:~$ 

And from Comcast:

traceroute to 9.9.9.9 (9.9.9.9), 30 hops max, 60 byte packets
1 Cisco00960 (192.168.127.1) 0.358 ms 0.276 ms 0.274 ms
2 96.120.90.141 (96.120.90.141) 10.568 ms 10.448 ms 17.767 ms
3 po-104-rur02.hayward.ca.sfba.comcast.net (68.87.195.233) 17.512 ms 17.279 ms 17.032 ms
4 po-2-rur01.hayward.ca.sfba.comcast.net (68.87.193.153) 15.069 ms 16.534 ms 16.271 ms
5 be-215-rar01.santaclara.ca.sfba.comcast.net (162.151.78.193) 16.273 ms 16.147 ms 16.457 ms
6 be-3651-cr02.sunnyvale.ca.ibone.comcast.net (68.86.91.73) 17.133 ms 13.754 ms 19.464 ms
7 be-11083-pe02.529bryant.ca.ibone.comcast.net (68.86.84.14) 18.294 ms 20.974 ms 25.530 ms
8 router.pao.woodynet.net (204.61.214.66) 15.549 ms 16.217 ms 16.131 ms
9 dns.quad9.net (9.9.9.9) 13.746 ms !X 13.831 ms !X 19.832 ms !X
pi@raspberrypi ~ $ 0

Re: Trouble using Quad9, bad traceroute from Sonic

Posted: Mon Mar 04, 2019 9:28 am
by sysops
I have a pretty much identical trace, but no issues with DNS resolution:

Code: Select all

# dig example.org @9.9.9.9

; <<>> DiG 9.10.3 <<>> example.org @9.9.9.9
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61751
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;example.org.         IN   A

;; ANSWER SECTION:
example.org.      43200   IN   A   93.184.216.34

;; Query time: 19 msec
;; SERVER: 9.9.9.9#53(9.9.9.9)
;; WHEN: Mon Mar 04 09:27:02 PST 2019
;; MSG SIZE  rcvd: 56


Strange traceroutes aren't always indicative of problems. Are you able to issue queries and get answers okay too?

Friendly reminder, Sonic's DNS resolvers are fast and on-network. 9.9.9.9 may have some advantages, but keep in mind that if you use it, all of your DNS requests are leaving Sonic's network and being sent over the internet in plain text for anyone in between to see and monitor your DNS traffic.