email to [me]@sonic.net appears reliably on iPhone but not always in Mac Mail

General discussions and other topics.
7 posts Page 1 of 1
by ankh » Wed Apr 18, 2018 5:53 pm
Puzzled. I see this question asked several times in Apple forums and never answered. Perhaps someone here has an idea?

Email sent to my Sonic address shows up consistently on an iPhone (set to IMAP) but some emails do not show up in Mac Mail on a Mac desktop (also IMAP). I don't see any particular pattern to identify the mail that's in this category.

I'm wondering
-- if it can be debugged, and
-- if not, if I just delete the iPhone mail account, will the missed emails show up in Mac Mail on the home desktop.

I'd be glad to work with anyone on trying to characterize the bug if anyone has suggestions what to try.
by virtualmike » Wed Apr 18, 2018 10:52 pm
ankh wrote:
-- if not, if I just delete the iPhone mail account, will the missed emails show up in Mac Mail on the home desktop.

It's possible your iPhone client is doing something with the emails, marking them on the server in a manner that the Mac Mail client is hiding them from you.

Are they still visible on the iPhone, even when you can't see them on the Mac? Do you see them in Web Mail?

I'm not a Mac user, but I'd check to see if there is a way to see all mail that it sees, regardless of which folder. For example, I use Thunderbird, and I can search by various criteria, across folders.

Deleting the account from the iPhone might help diagnose this--if the iPhone is not retrieving emails at all and they start showing on the desktop, then likely the iPhone is doing something with them.

Also, could this be something in iCloud synchronization between the iPhone and the Mac, where the Mac may be hiding email that has been viewed or had actions taken? Can you try a different mail client on the Mac? Thunderbird is free and supports IMAP, and doesn't sync with other devices through iCloud.
by miken » Thu Apr 19, 2018 8:56 am
The first step would probably be to log into Webmail at https://webmail.sonic.net. If the missing messages are located in there, then there's an issue with Mac Mail not displaying emails that are located on our server. If the messages can not be found in Webmail, the iPhone might be downloading messages off of our server.
Mike N.
Development Trainer
Sonic
by ankh » Thu Apr 19, 2018 9:15 am
The missing messages are not visible in webmail. Annoyingly, the Webmail display seems to have the messages in random order, not sorted by recentmost first. So I used the search tool. As an example, I report spam to Spamcop and used to get email from Spamcop saying a report had been received and is ready to process. None of those messages from Spamcop are visible in webmail or Mac mail as of recently, but they do show up on the iPhone.

But some messages do show up in all of the iPhone and Mac Mail and Webmail. It's inconsistent.

I'll look further into the iPhone settings. It's an old iPhone 4, iOS 7 (as updated as it can be).
by miken » Thu Apr 19, 2018 10:39 am
You can change sorting order via the Gear icon at the top left corner of the inbox. If you're Webmail is set to Widescreen view, you can also click the Date header and it will automatically sort that way.
Mike N.
Development Trainer
Sonic
by ankh » Tue Apr 24, 2018 12:42 pm
Thanks, sorting order fixed.
Mail problem continues (sporadic items of email show up on the iPhone and in Sonic Webmail, but do not appear in Mac Mail)
The missing email isn't in junkmail or trash.
by maffyew » Thu Dec 02, 2021 2:12 pm
Apple Mail and Sonic Mail have different folder assumptions. I find it usually helps to remap the folder behavior on the Apple client.

Mail folders:
    Apple: "Deleted Messages" = Sonic: "Trash"
    Apple: "Sent Messages" = Sonic: "Sent"
    Apple: "Junk" = Sonic: "Graymail"
7 posts Page 1 of 1

Who is online

In total there are 4 users online :: 1 registered, 0 hidden and 3 guests (based on users active over the past 5 minutes)
Most users ever online was 999 on Mon May 10, 2021 1:02 am

Users browsing this forum: Google [Bot] and 3 guests