Page 1 of 1

how to port forward ARRIS BGW210-700

Posted: Sun Dec 10, 2017 5:06 pm
by pathma
I would like to open port 22 and forward it to a machine behind the firewall. I went into
the Gaming tab on the Arris and tried the custom setup, but there's no prompt for the IP
address. How do I do this?


Re: how to port forward ARRIS BGW210-700

Posted: Sun Dec 10, 2017 6:45 pm
by pathma
OK, I figured this out. Had to create a custom service. In my case I want port XXXX -> port 22
Then used the custom service to map to discovered devices.

Re: how to port forward ARRIS BGW210-700

Posted: Fri Nov 02, 2018 9:49 am
by jayches
Fixed, firmware version 1.6.7 is the problem, which is why it works for some users and not others.

Can't count the hours I spent on this, and the discussion boards are littered with folks who can't get port forwarding to work on this same model gateway router, and others who say it works fine.

Depending on firmware version, this may or may not be applicable, but my recently-installed ARRIS BGW210-700 running firmware version 1.6.7 would not port forward port 80 or any other ports, could not get traffic to my web server on the local network, I used wireshark to capture packets and study its behavior. The port would open (would accept TCP connections) but it would not forward packets to the local network. Apparently most folks get around this by using IP Passthrough, which requires it have the public network IP, gateway, etc and makes it unavailable inside the local network as its on a different subnet then.

Bottom line - there is a bug in 1.6.7 (or perhaps it's intentional for some reason to disable this feature while making it appear to be availble), but from other postings, firmware version 1.5.x worked fine. ATT released a new version of firmware 1.6.9 which fixes broken port forwarding on 1.6.7, and it's available here: ... _1.6.9.bin

Go the the router upgrade option, don't disturb or powercycle the router while its doing the upgrade it fixed my problem and port forwarding works.

I'm not sure if this is needed (I put it in before doing the firmware upgrade which fixed the problem), but under packet filtering, there is a hidden "allow" option where you can "allow" a protocol/port and IP destination address of the local web server you're trying to make public, I allowed the port and IP in addition to the NAT entry I put in.