Procmail suddenly stopped working.

General discussions and other topics.
13 posts Page 1 of 2
by warriorz » Fri Mar 05, 2021 8:48 pm
Anyone else having problems with their procmail recipies ?

I have used procmail for quite a few years to sift my email. About 4 or 5 days ago I started seeing messages which were normally caught by procmail showing up in my main mailbox.

I logged into my shell account, turned on logging and sent several emails from a test account outside sonic to see if I could see anything in the logs.

Imagine my suprise when I found nothing. The last access times on my files were from when I last made changes, two years ago.

It looks like my procmail recipies have stopped being invoked by the mailer.

Any suggestions on avenues to pursue? Support had nada, and could only say that procmail was sorta there for people who know how to use it and have thrown me to the gentle mercies of the sonic user community.

Any hints/help would be much appreciated.

--J
by dane » Fri Mar 05, 2021 9:21 pm
I know that $home directory paths have changed, as a storage upgrade is underway. If you're using absolute paths instead of $home, that could be it!
Dane Jasper
Sonic
by warriorz » Sat Mar 06, 2021 12:17 pm
Thanks for taking the time to reply Dane,

I did check and found old hard-coded paths. Fixed to use $HOME and repeated testing, without success.

Also on the off-chance that something had changed with /etc/procmail, copied the procmail file to $HOME/.procmailrc . No joy.

I also wanted to confirm that procmail still uses the "procmailrc-email_user_name" as the procmail file to run when executing user procmail recipies.
by taa_sonic » Sat Mar 06, 2021 2:24 pm
This is a long shot, but the last time I had similar problems, they turned out to be due to encoding issues caused by changes at the sender's end. Turning on logging helped reveal this, though if you still have any of the messages that failed to filter correctly, you should be able to take a look at the headers and see if there's a UTF-8 character that your recipes won't match.
by gkeller » Sat Mar 06, 2021 4:48 pm
I took a quick look, and I think I fixed it. If not I'm going to need a bit more information on which messages in particular are not being filtered so I can dig in the logs. Two of your mailboxes had procmails that had includes to procmails that lived in the home directory for your primary account. I had gone through and verified that nobody had hardcoded their own home directory in .procmailrc, but I missed this case since it was the home directory for a different account. I updated that path on your mailboxes, so the procmails should be working correctly. If not let me know.
Grant Keller
Sonic.net System Operations
by warriorz » Sun Mar 07, 2021 11:21 am
Grant,

Thank-you for taking a look. Yes, that fixed it, I see my log file filling up again.

I thought mailboxes were not shell accessible, only the primary account otherwise I would have checked.

Anyway, thanks to everyone for thier comments and suggestions, we are back in action !
by warriorz » Tue Mar 16, 2021 5:42 pm
Sigh,

Stopped working again.

This is frustrating. Sonic should either fully support this service or remove it as an offering to its customers.
by nhdesign » Mon Mar 22, 2021 11:16 am
Hey Warriorz,

Did you procmail return to normal? What did you have to change on your setup?

Thanks,
nhdesign
by warriorz » Sun Mar 28, 2021 7:03 pm
No it did not. I thought Grant had fixed it (I saw my procmail log-file had been touched which would have indicated that a script ran), but subsequently found no change in procmail behavior and the logs are not being updated.
by gkeller » Mon Mar 29, 2021 5:47 pm
Can you confirm the procmails are still not working? I realized that I needed to update the log file path to point to your main account home dir. They had been writing logs, but into the mailbox accounts, so you couldn't have seen them.
Grant Keller
Sonic.net System Operations
13 posts Page 1 of 2

Who is online

In total there are 3 users online :: 0 registered, 0 hidden and 3 guests (based on users active over the past 5 minutes)
Most users ever online was 999 on Mon May 10, 2021 1:02 am

Users browsing this forum: No registered users and 3 guests