Setting up Sonic webmail in Outlook for Android

General discussions and other topics.
11 posts Page 1 of 2
by hpdelano » Tue Jan 11, 2022 10:23 pm
I couldn't find an answer in search, so I'm asking here. While the set up appears remarkably streamlined in Outlook for Android, I cannot get it to work. The server name should be mail.sonic.net, right?

I'm thinking the sticking point is the field where it asks for domain/username. I've tried just typing in my username with and without "@sonic.net" but it isn't working.

Anyone have a solution?
by virtualmike » Fri Jan 14, 2022 5:01 pm
mail.sonic.net for sending (outgoing). imap.sonic.net for receiving (incoming).

https://help.sonic.com/hc/en-us/article ... 3-Settings
by hpdelano » Fri Jan 14, 2022 11:29 pm
virtualmike wrote:
mail.sonic.net for sending (outgoing). imap.sonic.net for receiving (incoming).

https://help.sonic.com/hc/en-us/article ... 3-Settings


I've already seen that FAQ. But that's for the desktop version. There is no imap/pop setup in Outlook for Android.

There are fields for server, domain/username, and the password, that's all. I've tried every combo I can think of. The certificate comes up as invalid or I get server timeout errors.
by apl » Sat Jan 15, 2022 11:41 am
If it's asking you for a "domain" then it's trying to set it up as an Exchange account, which won't work.
It should be possible to set it up as an imap account instead, but apparently MS makes that difficult to find:
https://chemicloud.com/kb/article/how-t ... n-android/
by hpdelano » Sat Jan 15, 2022 11:58 pm
Thank you for the reply. I followed those instructions to the letter, now I just get login errors to check my email and password. Everything matches up. They're the same exact logins I use to for webmail in the browser. I wonder if Sonic is blocking this somehow?
by virtualmike » Mon Jan 17, 2022 11:10 pm
Sonic doesn't prevent people from using various apps to access their email.

Have you tried setting up to access from the native mail program on your Android device? That might be a good idea to ensure that there aren't any issues with the device itself. Otherwise, this suggests that something isn't configured correctly, whether Outlook's settings or the user ID/password.

Oh... one more thought. Ensure that Outlook is trying to login to hpdelano, not hpdelano (at) sonic (dot) net [I intentionally made your address difficult for spam harvesters to grab, but you get the point). I believe that Outlook on the PC assumes the login to the mailbox is the same as the email address, but that's not the case for Sonic.
by hpdelano » Tue Jan 18, 2022 8:54 pm
virtualmike wrote:
Sonic doesn't prevent people from using various apps to access their email.

Have you tried setting up to access from the native mail program on your Android device?


I used Samsung's own email app and all it took was merely inputting my email and account password and my Sonic inbox showed up instantly. Yes, it was literally that simple. Microsoft somehow cannot make it that simple.
by virtualmike » Tue Jan 18, 2022 10:43 pm
So we've ruled out the device itself, which means it's an issue with the configuration or the login details.
by ngufra » Wed Jan 19, 2022 7:45 am
I tried and i agree it's not the best UI.

Start outlook for android
click on top menu button, click on gear (settings) and select "add mail account".
3 options open. select "Add an email account"
if it detects other email accounts, ignore them.
In Add account panel, enter your sonic account and press continue.
It will display a dialog "Connect to exchange" asking for server, domain\username and password.
CLICK ON THE QUESTION MARK at top and CHANGE ACCOUNT PROVIDER select IMAP

You will then be able to enter the sonic imap server name and port, password etc; same for smtp

Please confirm it works for you after you switch mail serer type from exchange to imap.
by hpdelano » Wed Jan 19, 2022 12:43 pm
ngufra wrote:
I tried and i agree it's not the best UI.

Start outlook for android
click on top menu button, click on gear (settings) and select "add mail account".
3 options open. select "Add an email account"
if it detects other email accounts, ignore them.
In Add account panel, enter your sonic account and press continue.
It will display a dialog "Connect to exchange" asking for server, domain\username and password.
CLICK ON THE QUESTION MARK at top and CHANGE ACCOUNT PROVIDER select IMAP

You will then be able to enter the sonic imap server name and port, password etc; same for smtp

Please confirm it works for you after you switch mail serer type from exchange to imap.


I've tried everything. I just can't get it working in Outlook for Android. I'll just have to make do with Samsung's mail app.
11 posts Page 1 of 2

Who is online

In total there are 5 users online :: 0 registered, 0 hidden and 5 guests (based on users active over the past 5 minutes)
Most users ever online was 999 on Mon May 10, 2021 1:02 am

Users browsing this forum: No registered users and 5 guests