Anyone know how to enable Zip Archive extension for PHP in Wordpress?

Advanced feature discussion, beta programs and unsupported "Labs" features.
2 posts Page 1 of 1
by dwhittaker » Wed Nov 28, 2018 5:35 pm
I've installed a migration plugin for Wordpress to migrate a website I just finished to the domain root directory. It's the top rated plugin for migration and I'd like to use it but upon it's initial system requirements test, it keeps failing and gives me a "Zip Archive Enabled: Fail" error. The corresponding information says "For compression to work the ZipArchive extension for PHP is required." I'm running the current version of PHP so that's not the issue.

The weird thing is, this plugin works fine on my own Wordpress based website. Both mine and my clients sites use the exact same Theme and have pretty much the exact same plugins active. I have no clue where to find the reference to this Zip Archive extension in the myriad of PHP files in my Wordpress installation either.

Anyone have any suggestions?

Attachments

by drew.phillips » Thu Nov 29, 2018 3:04 pm
The zip extension and ZipArchive libraries are built into PHP and can't be enabled dynamically.

The reason zip is not included in our PHP 5.6 install is due to PHP build issues with that particular library and other PHP modules we have included in PHP 5.6. It's unfortunate that we can't get that included with our platform but is a technical limitation that we are unable to overcome at this time. Enabling PHP's built in zip library causes the entire build process to fail at the very end due to issues linking things together.
Drew Phillips
Programmer / System Operations, Sonic.net
2 posts Page 1 of 1

Who is online

In total there are 4 users online :: 0 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 422 on Sat May 26, 2012 5:28 am

Users browsing this forum: No registered users and 4 guests