Struggling with OpenVPN client on Asuswrt-Merlin

Advanced feature discussion, beta programs and unsupported "Labs" features.
2 posts Page 1 of 1
by kolohe » Tue Feb 20, 2018 4:29 am
I've been struggling with trying to get the OpenVPN client on Asuswrt-Merlin 384.3 to work. I've used the client.ovpn file on other devices, but I've had no luck with this router. Here's my log:

Feb 20 03:53:35 ovpn-client1[1364]: TCP: connect to [AF_INET]209.148.113.36:1194 failed: Connection timed out
Feb 20 03:53:35 ovpn-client1[1364]: SIGUSR1[connection failed(soft),init_instance] received, process restarting
Feb 20 03:53:35 ovpn-client1[1364]: Restart pause, 40 second(s)
Feb 20 03:54:15 ovpn-client1[1364]: WARNING: --ns-cert-type is DEPRECATED. Use --remote-cert-tls instead.
Feb 20 03:54:15 ovpn-client1[1364]: NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Feb 20 03:54:15 ovpn-client1[1364]: TCP/UDP: Preserving recently used remote address: [AF_INET]209.148.113.36:1194
Feb 20 03:54:15 ovpn-client1[1364]: Socket Buffers: R=[87380->200000] S=[16384->200000]
Feb 20 03:54:15 ovpn-client1[1364]: Attempting to establish TCP connection with [AF_INET]209.148.113.36:1194 [nonblock]
Feb 20 03:54:19 ovpn-client1[1364]: TCP: connect to [AF_INET]209.148.113.36:1194 failed: Connection timed out
Feb 20 03:54:19 ovpn-client1[1364]: SIGUSR1[connection failed(soft),init_instance] received, process restarting
Feb 20 03:54:19 ovpn-client1[1364]: Restart pause, 80 second(s)
Feb 20 03:55:39 ovpn-client1[1364]: WARNING: --ns-cert-type is DEPRECATED. Use --remote-cert-tls instead.
Feb 20 03:55:39 ovpn-client1[1364]: NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Feb 20 03:55:39 ovpn-client1[1364]: TCP/UDP: Preserving recently used remote address: [AF_INET]209.148.113.36:1194
Feb 20 03:55:39 ovpn-client1[1364]: Socket Buffers: R=[87380->200000] S=[16384->200000]
Feb 20 03:55:39 ovpn-client1[1364]: Attempting to establish TCP connection with [AF_INET]209.148.113.36:1194 [nonblock]
Feb 20 03:55:43 ovpn-client1[1364]: TCP: connect to [AF_INET]209.148.113.36:1194 failed: Connection timed out
Feb 20 03:55:43 ovpn-client1[1364]: SIGUSR1[connection failed(soft),init_instance] received, process restarting
Feb 20 03:55:43 ovpn-client1[1364]: Restart pause, 160 second(s)

On a different note, would it be possible to use a third-party DNS server with the VPN instead of Sonic's defaults? I'd like to use AdGuard DNS.
by guest » Sun Mar 11, 2018 12:54 pm
Try changing the protocol to UDP.
2 posts Page 1 of 1

Who is online

In total there are 6 users online :: 0 registered, 0 hidden and 6 guests (based on users active over the past 5 minutes)
Most users ever online was 422 on Sat May 26, 2012 5:28 am

Users browsing this forum: No registered users and 6 guests