VPN and iPad

Advanced feature discussion, beta programs and unsupported "Labs" features.
4 posts Page 1 of 1
by Xe01 » Mon Jun 26, 2017 9:13 pm
I am trying to functionalize the Open VPN app on my iPad (iOs 10.3.2 (14F89)).
I successfully installed the app, but when I try to import a profile from opvn.sonic.net, it asks me for my Sonic user name and Sonic password. Persistently, these are rejected, and I see "Login failed." I am certain that the user name and password are correct, as I have no difficulty with them if I directly go to the Sonic site, as I am doing now.
I am thus unable to download a sonic vpn profile to use for this.
I should add, that I have had no problem using the Sonic vpn on my desktop PC.
Is there something special with an iPad that needs to be done to use the open vpn?
I will be traveling shortly, using open systems, and would prefer to have a measure of security via the vpn.
Any suggestions please?

Thanks
by drew.phillips » Tue Jun 27, 2017 11:23 am
Are you by chance using any capital letters in your username or appending @sonic.net?

There's an outstanding issue that OpenVPN user names are case sensitive and must be entered in all lowercase. We're awaiting a fix. The login name also is just your username and does not include @sonic.net or any other domain.

If that doesn't help, can you send me a private message on the board with your username and I can take a look?
Drew Phillips
Programmer / System Operations, Sonic.net
by Xe01 » Tue Jun 27, 2017 2:44 pm
That was it!!
Thank you.
The first letter of my username was capitalized by default, and I had paid no attention to it because elsewhere it is not an issue.
Fixing that, fixed the problem.
I have access and all seems to be running well.
In terms of speed, is it possible that things are slightly faster on the vpn than off? I am measuring using the HTML test, not the flash one.
Thanks.
by drew.phillips » Tue Jun 27, 2017 2:59 pm
Hi Xe01, I'm glad that was it! Sorry for the inconvenience. We tried an existing option to make usernames case-insensitive but it does not work with our authentication system so we're waiting for an appropriate fix.

I have at times observed speed tests appearing to be faster when on the VPN (especially with Fusion FTTN). There are a number of factors that contribute to that (UDP, compression, our VPN's close path to major carriers etc). One thing to note is that our speed test server and VPN server are in the same location so that could contribute as well.

I'm happy to hear it's working well now. If you have any other questions don't hesitate to ask.

Thanks!
Drew Phillips
Programmer / System Operations, Sonic.net
4 posts Page 1 of 1

Who is online

In total there are 2 users online :: 0 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 422 on Sat May 26, 2012 5:28 am

Users browsing this forum: No registered users and 2 guests