Problems port forwarding on gigabit

Internet access discussion, including Fusion, IP Broadband, and Gigabit Fiber!
13 posts Page 1 of 2
by Forwarder26 » Tue Aug 07, 2018 6:39 pm
I have sonic gigabit and am having trouble with forwarding a port.
I use the Smartrg router that was provided with my installation. According to the router's configuration page, the port is open. However, all indications are the port is still closed, so I suspect the ONT is at fault. I tried connecting my computer directly to the ONT, but I couldn't figure out how to get to a configuration page, if there is one. Nothing loaded when I tried entering the internal IP adress, or the address to the router's admin page. ( into my browser.

Am I on the right track? Is there a way to configure the ONT?

Thanks for any help you may have.
by miken » Wed Aug 08, 2018 12:36 pm
There is no way to configure the ONT as it's a bridged device. What port are you trying to open? By default we only block Port 25, for obvious reasons.
Mike N.
Development Trainer
by Forwarder26 » Wed Aug 08, 2018 11:07 pm
I'm attempting to open port 25565...According to the configuration page, the port is open, but none of the port checking web apps I tried could find it. I tried restarting the router, but it didnt seem to do anything.
by miken » Thu Aug 09, 2018 1:56 pm
The SmartRG does use something called "Port Triggering" which is a little different than just leaving a port open. I'd be happy to take a deeper look into this. If you send me a private message here on the forums with what kind of connection you are trying to achieve with the open port I can get some more information for you.
Mike N.
Development Trainer
by Ryan Grant » Fri Oct 05, 2018 4:02 pm
I too am trying to open port 25565 for the exact same reason that guy is.... probably. Please reach out to me if you have figured it out, his post is my problem as well.
by ds_sonic_asif » Wed Jul 17, 2019 5:08 pm
Does anyone have a working recipe for port triggering on the SmartRG SR516ac?

And backing up a step... Is port triggering the right way to make listeners on a LAN visible on the WAN? The verbiage here is somewhat ambiguous:

Some applications such as games, video conferencing, remote access applications and others require that specific ports in the Router's firewall be opened for access by the remote parties. Port Trigger dynamically opens up the 'Open Ports' in the firewall when an application on the LAN initiates a TCP/UDP connection to a remote party using the 'Triggering Ports'. The Router allows the remote party from the WAN side to establish new connections back to the application on the LAN side using the 'Open Ports'.

Perhaps this should be done in the Virtual Servers section (which doesn't have a documentation link, but it just above the port triggering section.


Edit: I tried the following:
- Add a static IP address in the LAN DHCP configuration section for my server.
- Add a Virtual Server entry for the port I want to expose, using that port number, the static IP of my server, and leaving the "Use Interface" pulldown to the default, atm0.1
- Reboot the router.

My server gets assigned the expected IP address, the Virtual Server rule shows up, but externally, the port is not open.
by ds_sonic_asif » Wed Jul 17, 2019 6:23 pm
And for full disclosure, I am running a firewall on the sever, but I believe it to be configured correctly, as I have been using this particularly software for many years. On the other hand Ubuntu has changed many things in recent releases (systemd and netplan figuring prominently in this tale).

So, I next tried turning off the server firewall (trusting that the router's would suffice). Still no joy.
by js9erfan » Wed Jul 17, 2019 9:21 pm
Have you temporarily tried putting your server in DMZ? If the server port is reachable from the WAN side after setting it as a static DMZ host then chances are the SR516ac's firewall is blocking communication or the port triggering/virtual server rules need attention. If it’s still not reachable after putting it in the DMZ then look at your server's firewall rules or another application on the server that may be blocking that inbound communication. This assumes the server application you're trying to reach from the WAN side is waiting to accept connections and is configured correctly. You could try changing ports as well in case it’s getting blocked upstream from your gateway. Nmap is a useful tool if you haven’t tried it.

I don't have a SR516ac to play with but that's where I would start.
by ds_sonic_asif » Wed Jul 17, 2019 9:34 pm
js9erfan, thank you! nmap has been in the toolbox for a long time.

The problem turned out to be the interface selection in the Virtual Server rule. Changing it to eth4.1 does the desired port forwarding.
by metaphysician » Thu Apr 16, 2020 11:58 am
i'm also having issues with port triggering on gigabit fiber with SmartRG SR516ac. mine is a standard connection, no extra servers or anything. i have set up Port Triggering on all three interfaces (atm,ptm, and eth4-1) but multiple test sites indicate the external WAN port is still closed. the port i need open is 50000.

is there anything else that must be configured for this to work? NAT is on on the router under WAN configuration, and i'm not forwarding to a different port number on my destination machine as far as i know. DMZ and Virtual server are unconfigured. any help would be appreciated!
13 posts Page 1 of 2

Who is online

In total there are 7 users online :: 1 registered, 0 hidden and 6 guests (based on users active over the past 5 minutes)
Most users ever online was 964 on Tue Sep 29, 2020 11:23 pm

Users browsing this forum: psireau and 6 guests