OpenWRT, AT&T and IPv6

Internet access discussion, including Fusion, IP Broadband, and Gigabit Fiber!
2 posts Page 1 of 1
by mpiechotka » Sun Dec 05, 2021 12:35 pm
Hi,

I have problems with setting up OpenWRT and IPv6. On Comcast it worked but it looks like Sonic/AT&T box is filtering the 6to4 connection even if the IPv6 is disabled for LAN.

Is it possible to get a IPv6? Or at least a modem which does not filter IPv6 (recommendation for dumb box equivalent of DOCIS modem are welcome - I presume I can get PPP data from Sonic)?
by michaelsanders » Thu Dec 16, 2021 4:12 pm
After a lot of searching online I was able to get it working with the following:

/etc/config/network

Code: Select all

config interface 'wan6'
        option proto '6rd'
        option peeraddr '184.23.144.1'
        option ip6prefix '2602:240::'
        option ip6prefixlen '28'
       
        # The entries below are optional but sped up my connection.

        # See https://tools.ietf.org/id/draft-foo-v6ops-6rdmtu-01.html
        option mtu '1480'

        # Cloudflare DNS
        option peerdns '0'
        list dns '2606:4700:4700::64'
        list dns '2606:4700:4700::6400'


Then reboot or run:

Code: Select all

/etc/init.d/network restart


I'm using Sonic ADSL through AT&T with a PACE 5268AC rental modem bridged via LAN subport (had to call support to get it working - the default bridging on the web interface was not functional on either IPv4 or IPv6). IPv6 tunnel must be enabled at https://members.sonic.net/labs/ipv6tunnel/

Sources:

- https://www.timdoug.com/log/2014/04/17/
- https://help.sonic.com/hc/en-us/article ... _or_5268ac
- https://openwrt.org/docs/guide-user/net ... otocol_6rd
2 posts Page 1 of 1

Who is online

In total there are 8 users online :: 0 registered, 0 hidden and 8 guests (based on users active over the past 5 minutes)
Most users ever online was 999 on Mon May 10, 2021 1:02 am

Users browsing this forum: No registered users and 8 guests