Trouble using as mail relay - has something changed on your end?

Internet access discussion, including Fusion, IP Broadband, and Gigabit Fiber!
5 posts Page 1 of 1
by oddhack » Wed Dec 09, 2020 8:13 pm
I'm running postfix on my Debian box configured to use []:587 as the relayhost. Starting December 3rd, I began getting a lot of "(unable to look up host Name or service not known)" errors in the logs, and queued mail backing up locally. Absolutely nothing about my local mail software or configuration changed since last summer, nor has my password on Sonic, and I can successfully lookup and connect to it on port 587 via telnet.

Did anything change on the Sonic end that would be causing this, before I start trying to generate more verbose logs to better diagnose what's happening locally?
by oddhack » Wed Dec 09, 2020 8:48 pm
Talked with support for a while. They are seeing incoming (edit: SMTP, presumably) connections which authenticate successfully, but nothing that helps diagnose why mail isn't being accepted. Looks like cranking up the log verbosity is the only way forward, for the moment, but if anyone else is running into this that would be good to know. I'm running Postfix 3.4.14-0+deb10u1, binaries dated from last June.
by oddhack » Thu Dec 10, 2020 5:05 am
I worked on this quite a bit more tonight, and eventually found that it is probably some manner of obscure nameserver problem, as replacing with the EMSTP server's IP address got outgoing email working. But I'm at a loss as to what the NS problem is, if so. I can do DNS lookups, dig, telnet to port 587, all that stuff - yet Postfix insists on coughing up a "relayhost configuration problem" / "unable to look up host Name or service not known" errors when trying to relay mail. N.b. I have to use Google nameservers, as the Sonic ones don't seem to allow lookups from a Comcast IP (I am just an email customer until Sonic rolls fiber in Hayward :-( ).

I haven't changed anything relevant in my OS or postfix setup in the timeframe that this problem started happening, so it seems likely to be *something* happening on the Sonic end.
by oddhack » Thu Dec 10, 2020 8:59 pm
After more hair-tearing I eventually discovered that postfix runs in a chroot with its own copy of /etc/resolv.conf, and NetworkManager thoughtfully wiped that out completely when I had to switch over to tethering to my phone during a Comcast outage. So DNS queries from my shell worked fine but postfix had no NS to look at, and reported an error message not giving any insight into the situation.

I really hate NetworkManager.
by kgc » Mon Dec 21, 2020 1:40 pm
oddhack wrote:
I really hate NetworkManager.

You're not alone.
Kelsey Cummings
System Architect,, Inc.
5 posts Page 1 of 1

Who is online

In total there are 5 users online :: 1 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 999 on Mon May 10, 2021 1:02 am

Users browsing this forum: Bing [Bot] and 4 guests