Disconnect every 5 minutes, firewall DHCP?

Internet access discussion, including Fusion, IP Broadband, and Gigabit Fiber!
33 posts Page 3 of 4
by thulsa_doom » Wed Sep 18, 2013 12:57 pm
Alas, sometimes the only thing that will mess a computer up worse than a virus is security software. A problem we used to see all the time with every-five-minute cutouts was when a security-minded router or piece of software refused to accept acknowledgments from our server due to stateful packet inspection.

During the Discover->Offer->Request->Acknowledge cycle, we give the end-user's device a five-minute lease. Halfway through the lease a well-behaved DHCP client will request that the lease be extended and we send an acknowledgement back, saying "sure thing, keep the lease for another five minutes."

If the acknowledgement is dropped by security software (perhaps because the acknowledgement came from a different port on our server than the original lease), the DHCP client assumes its lease has expired after five minutes (even though we extended it) and it starts the process all over again. For a moment the end-user doesn't have an IP address and all manner of confusion and delay follows. All in the name of stopping a phantom third party from issuing a DHCP acknowledgment.

I could have sworn we made changes on our end years ago to prevent this, though.
John Fitzgerald
Sonic Technical Support
by digitalbitstream » Fri Sep 20, 2013 2:34 pm
I had this problem for a while, with the Actiontec GT701D if I recall. I switched to static IP which seemed pretty painless and solved a different problem at the same time. No virus or security software was involved, but I agree with the above sentiment.
by thoth » Sat Sep 21, 2013 11:36 am
Ordered a router. Will keep you all posted on if it fixes my drops. Thanks for the help. Sorry if I hijaked this thread a bit.
by thoth » Sun Sep 22, 2013 10:54 pm
So sadly my new $50 load balancing multi-wan router (overkill i know) didn't solve my drop issue. It just dropped for a few seconds...got like 7 or 8 missed pings (using -t) and no internet access and yellow exclamation mark icon in network status system tray.

So I am at a loss. So far if I recall the only thing that seems to fix drops is the removal of anti-virus software. And for some reason I get less drops I think when I have Sonic downgrade my down/up speeds. But who knows if those things do anything...could have been coincidence that drops stopped temporarily when I tried those things.

Could this simply be a line issue? The phone line has to go quite a way to reach my apartment.

Another clue...I had no drops at all for 2 years...then Direct TV shows up and does something on my roof for my neighbors and then all of a sudden...drops since then. My phone line goes up onto my roof. I do know that. Had Sonic tech come out...then Sonic and ATT at same time...they tested line and deemed it okay. ATT changed junction box out front is all that was done. But none of this fixed my problems.

If anyone has any ideas on all this I'd be most appreciative.


PS - Kept modem as bridged setup.
by KC Sonic » Tue Sep 24, 2013 8:18 am
I had an old Netgear router that did the same thing, so adding a router by itself will not resolve this issue.

Mine happened when the old modem provided by Sonic.net overheated and stopped working. There were problems when I first signed up and Sonic dispatch an excellent tech guy to check on my line. He had made a few other adjustments on my equipment. I lost all my previous settings on the router when I replaced with new netgear modem (in bridge mode) and had to reset my router to work. Since then, I have seen a 5 min dhcp renewal thing like the poster.

It seems the problem is originated from the router refusing "something" so it constantly connects & disconnect. I had sent in an e-mail for sonic tech, but really it is out of their scope to provide support on this. However, I found on the internet that sonic had provided a command line for those working with dd-wrt (openning some ports?) to fix this issue. Could this be a port forward or port trigger command that users like us can implement on our router if a simple instructional sample on one router can be shown in Sonic Wiki? We just go look up for info on our specific brand on how to do the same?
by desertflyer » Tue Sep 24, 2013 10:21 am
Why don't you try setting a static IP (it's free under Member Tools) and see if that resolves the issue. That would definitely narrow down if it was a problem with the DHCP lease time or not.
by KC Sonic » Tue Sep 24, 2013 8:14 pm
How to set up using one static IP for all these devices normally connected via wifi from wireless router?
by desertflyer » Wed Sep 25, 2013 12:57 pm
You change your router connection from DHCP to Static, but your local network will still use DHCP (nothing changes there). Your router documentation should be able to outline the specifics of this more.
by thoth » Fri Oct 25, 2013 10:49 pm

Used Member Tools to switch to static IP, but connection dropped within an hour. So now I'm at a loss. Happens in dynamic or static.

Brand new router.

Starting to think it's the line. Or anti-virus software. At one point I did uninstall anti-virus and no drops, but could have been a coincidence.
by o.b.1 » Thu Dec 19, 2013 8:56 pm
Had the same problems as you. I looked inside Avast and found a setting for web browsing protection, I turned it off and BOOM, internet is back, and no disconnects.
33 posts Page 3 of 4

Who is online

In total there are 13 users online :: 2 registered, 0 hidden and 11 guests (based on users active over the past 5 minutes)
Most users ever online was 999 on Mon May 10, 2021 1:02 am

Users browsing this forum: Bing [Bot], Google [Bot] and 11 guests