D-Link ADSL2+Modem DSL-520B

Internet access discussion, including Fusion, IP Broadband, and Gigabit Fiber!
7 posts Page 1 of 1
by pehill » Sat Aug 24, 2013 4:31 pm
Has anyone set up a D-Link+Modem model DSL520B to work on Sonic AT&T DSL?
If so can you please provide setup info?
by torstenb » Mon Aug 26, 2013 7:27 am
The following assumes that you plan on using a (wifi) router connected to the modem, even though operating a computer connected directly to the modem should work the same way. It also assumes that you don't have a static IP setup with Sonic.net, in which case you'd have to enter the IP address, DNS, Gateway etc. manually into your (wifi) router or computer after completing the below steps.

1.) Connect your modem to the phone/DSL line. Attach your computer directly to the modem.
2.) Press the reset button on the back of the modem until the modem resets then releases the reset button.
3.) Once the modem reboot is complete, your computer should receive an IP address from the modem (in the 192.168.1.x range)
4) Open a browser, go to 192.168.1.1 and enter user and password. In case you see the modem's software update page, turn off the modem, wait 10 seconds and turn the modem back on. Then repeat this step. (BTW: I had difficulty performing the steps using Firefox on windows, but it worked using Internet Explorer.)
5) Use the modem's quick setup. When prompted, make sure the following values are being used:
VPI: 0, VCI:35, Service category: UBR without PCR, [NEXT], Connection type: bridging, Encapsulation: LLC/... [NEXT] Enable bridge service: <checked>, Service Name: <whatever you like or leave as is>, [NEXT], [SAVE] -> The modem should reboot at this point
6) Once the modem has finished rebooting, go to 'Advanced Setup' -> 'LAN', uncheck 'Enable DHCP server', then click 'Save & Reboot'.
7) Disconnect your computer from the modem and connect your (wifi) router to the modem.

Done.
by kristen2kentng » Wed Aug 28, 2013 3:34 pm
I've used both D-Link DSL-2540B and 2640B successfully with Sonic.net. Here are two articles that I found useful for setup:

https://forums.sonic.net/viewtopic.php?f=10&t=140
https://wiki.sonic.net/wiki/D-Link_DSL-2640B
by Malcolm Kettering » Sat Sep 14, 2013 10:08 am
Just bought one of these online. I'll report back here once I (hopefully) get it up and running with Sonic Fusion.
by musicalfruit » Mon Oct 24, 2016 9:25 pm
@torstenb

Found this topic via Google and wanted to thank you for listing the steps needed to setup a DSL-520B.

I was really scratching my head as the default settings did not work at all with Sonic's Fusion service.

Thanks again!
by seamas@sonic.net » Thu Aug 23, 2018 12:15 am
Just posting to (i) report another success with these instructions (under Linux and using Firefox for the configuration) and (ii) to thank torstenb for posting the recipe and releasing me from a day of frustration and failure,

JMcC
by billcour » Mon Oct 08, 2018 9:28 am
I used these instructions -- for which thanks -- to get an Apple AirPort Extreme and D-Link DSL-520 working together. A couple of modem config items didn't match what I saw on my screen, so I let them be.

A key for me was to be sure that DHCP Server is disabled on the modem and that on the Airport, Network > Router Mode = DHCP and NAT. The latter setting, by the way, is required to make a wireless Guest Network work on the Airport.
7 posts Page 1 of 1

Who is online

In total there are 11 users online :: 0 registered, 0 hidden and 11 guests (based on users active over the past 5 minutes)
Most users ever online was 422 on Sat May 26, 2012 5:28 am

Users browsing this forum: No registered users and 11 guests