by djoliverm » Thu Mar 19, 2020 4:42 pm
Hello! So I have a Google Wifi setup at home and the main puck is plugged directly into the ONT. One thing I did notice is that after switching from Wave cable internet and to Sonic Gigabit fiber, I couldn't do any internet speed tests within the Google Wifi app as it gives me the following error whenever I try: "Oops, there was a connection issue and your Network check was not completed."

Searching online I did find a Google support response where it said that it may be possible that there is a Double NAT somewhere that could cause issues with Google Wifi connecting to the Google Cloud servers. https://support.google.com/googlenest/thread/681268?hl=en

2. Double NAT - It happens when you connected your Google wifi to an upstream 3rd party router or to a ‘modem/router’ device, a firewall from these devices are more likely blocking Cloud Services reason for it not to sync properly with the app. If yes, check out these following recommendations.
Set a DMZ on the upstream router
If possible, bridge the upstream router.
Disable the firewall and wireless of the upstream router.


I'm not entirely sure if this is the issue since the ONT is supposed to be a passive device, but somehow Google Wifi was able to connect to Google's cloud servers to do the background speed checks before Sonic, and after Sonic it's never been able to. I also can't seem to get Google Wifi to set a different DNS than the default Google ones so I'm not sure if this is related to that or not.

I would greatly appreciate any help from other people who do have the same setup and can successfully do a speed test within the Google Wifi app (where they can see the history of speed tests over time vs it just being blank). I can do a speed test through other means no problem, but having that chart over time of the typical speeds was always nice to have to assess the connection.

Thanks!