A certain website can't be accessed

Internet access discussion, including Fusion, IP Broadband, and Gigabit Fiber!
4 posts Page 1 of 1
by rcgwang689 » Thu Jan 30, 2020 5:25 pm
Using my iPhone or laptop, under Sonic network, a website "www.meipian.cn" can not be accessed. However, under AT&T or Comcast networks (my friends' houses nearby), or under Verizon network, this website can be accessed smoothly. I called Sonic customer service three times, unfortunately, this issue has not been solved yet.
by rcgwang689 » Thu Jan 30, 2020 6:14 pm
This website name ends with "cn". Does this matter? Sonic network does not recognize cn domain?
by joeyyung911 » Thu Jan 30, 2020 7:31 pm
Seems like a DNS issue on Sonic's end, using Google's worked.
Excelsior, Sonic Fiber
by larns576 » Thu Jan 30, 2020 7:46 pm
Some virus scanners / internet security software, such as Eero Secure, can also block certain web sites. Disable them and they again. Also try using a different DNS server as someone else had suggested. Works on my Sonic connection with Cloudflare.
4 posts Page 1 of 1

Who is online

In total there are 11 users online :: 2 registered, 0 hidden and 9 guests (based on users active over the past 5 minutes)
Most users ever online was 700 on Thu Jun 18, 2020 12:00 pm

Users browsing this forum: Google [Bot], Majestic-12 [Bot] and 9 guests