after 3 days internet still down -- major tech support hassle -- ATTN: Dane?

Internet access discussion, including Fusion, IP Broadband, and Gigabit Fiber!
6 posts Page 1 of 1
by racerlupine » Wed Dec 04, 2019 2:21 pm
A synopsis of this week's encounter with Sonic tech support:

12/2/2019
1) After three years of solid reliable service my Sonic connection crapped out. After confirming the integrity of the wiring in my apartment I called Sonic; they determined the issue was outside the building and arranged for an ATT tech visit.

12/3/2019
2) Called Sonic: Due to a severe backlog of issues after the recent storm ATT still had not even scheduled my tech visit.

12/4/2019
3) Called Sonic: ATT tech visited and corrected the issue that was outside the building. This did not correct my issue, however. The support person tried to ping my modem, I couldn't get him to say whether successfully or not. (I can't ping my home server so it's still offline.) He puts me on hold for 8 minutes; then says the issue is easy to resolve with a truck roll to my address.

4) Then he tells me I have to pay for the truck roll -- why? because I'm not using a Sonic modem. But I AM, the Pace 5268AC. Hmmm ... then another 10 minutes on hold.

5) When he returns he tells me my modem was returned within a week of opening the account. So Sonic shows me as NOT using their modem. EXCEPT it also shows a replacement Pace being shipped to me at the same time the first one was returned. I explained to him that at the time (three odd years ago) the first modem conked out after a week, I was instructed to return it (which I did) and a replacement would be sent (which it was). He goes hmmm some more and tells me Sonic has been billing me, and I've been paying, the equipment fee all this time. Even though Sonic my account shows me using a non-Sonic modem, I have been billed for a Sonic modem.

6) More time on hold then he says he has a "workaround". He will send me a new modem, which will be registered to my account, then I can get free truck roll. Not only that but I can possibly -- possibly -- get a refund of the three years equipment rental fees I've been paying. But if I want a truck roll now I will have to pay for it.

Really? That isn't a "workaround"; what it is, is bullshit. All this time I have faithfully been paying the fees, AND putting up with that crappy router in the Pace, PRECISELY because I knew an issue like this would come up sooner or later and I wanted to be covered.

Let me make this clear: Despite paying the fees, and using the modem, FOR THREE YEARS, I am not going to get the free truck roll (which really isn't free after all, it's actually prepaid) because (apparently) of some glitch in Sonic's record keeping.

I don't want a new modem. I don't want a refund. I want my Internet fixed, something for which I have already paid in advance. It's been down three days now going on four. This is not good enough -- not even close.

I love Sonic. They've always been great to me. But this is the limit. I need to get my connection fixed -- like within 24 hours -- or I'm switching to Comcast -- AND getting my fees refund from Sonic.

Thank you for your attention.

RACER
by racerlupine » Wed Dec 04, 2019 3:45 pm
Here's the follow-up to this matter:

12/4/2019
7) I just got off the phone with Jareile (I hope that spelling's correct, my man), Sonic tech support supervisor. He sorted out the vagueries of my account and my tech issue. Long story short: I'm getting my free truck roll TOMORROW! That's just fantastic, many thanks to everyone who helped me with this, from Dane on down.

Sonic RULES!

RACER
by ahah64 » Sat Dec 14, 2019 7:44 pm
You're lucky it's been a week since my internet and phone went out. I've been having problems since before Thanksgiving. At least then I had some internet. AT&T supposedly "fixed" it. If by fixing it the completely cut off my internet and made my phone line go completely dead. AT&T is supposed to be here by 8pm tonight, it's now 7:45pm, so I doubt it. Another ticket can't be put in until Monday.
by racerlupine » Sun Dec 15, 2019 3:20 am
I'm sorry to hear that you're having so much trouble. In my case a cable connecting my building to the pole was severed in the storm. All the landlines and internet were out in my building for three days -- numerous folks called in for service, including building management, but I know for a fact that it was my call to Sonic that got ATT out here. ATT corrected the severed cable but didn't follow through to actually get my service working again. It took a Sonic truck roll to do that.

Sonic really came through for me on this one, and not for the first time either.

RACER

ps= I know this sounds dumb but: have you made certain that your issue isn't within your own space and wiring? It's worth double checking, and if the issue IS there you can fix it pronto.
by ahah64 » Sun Dec 15, 2019 7:43 am
Yes, l am in contact with Sonic, they have worked with us. Asked us to disconnect at the box outside to test the line coming to the house. Thee problem is not in the house. AT&T is the problem.
by ahah64 » Sun Dec 15, 2019 7:42 pm
AT&T fixed the line on the outside of the house today.
6 posts Page 1 of 1

Who is online

In total there are 11 users online :: 0 registered, 0 hidden and 11 guests (based on users active over the past 5 minutes)
Most users ever online was 700 on Thu Jun 18, 2020 12:00 pm

Users browsing this forum: No registered users and 11 guests