can’t connect to Fusion with D-Link DSL-520B

Internet access discussion, including Fusion, IP Broadband, and Gigabit Fiber!
5 posts Page 1 of 1
by davekohr » Sat Aug 13, 2011 9:49 am
I’m a Sonic Fusion customer. I have successfully been using a 2Wire 1000SW as my DSL modem for many years, including the last 9 months or so that I’ve been on the Fusion plan. I wanted to get somewhat better speeds, so I got a D-Link DSL-520B, which supports ADSL 2+ (the 2Wire supports just ADSL 1). I’ve tried several different configurations, but have been unable to get an Internet connection with the 520B.

The 520B has two LEDs for the WAN (DSL) connection, one is for the DSL synchronization state, and the other is for the modem’s Internet connection state (i.e. does it have an IP address). The modem gets DSL synchronization just fine (the LED becomes solid green), and its admin Web page shows uplink/downlink speeds that look about right. But the Internet connection LED never goes green, it always stays unlit. The modem’s manual says this could mean one of 3 things: it doesn’t have an IP address, authentication failed, or the modem is in bridge mode. I’ve tried to get it to connect both in bridge mode and with PPPoE, but neither work. What’s the right kind of connection to use? With bridge mode, I tried this configuration manually:

PORT / VPI / VCI:0 / 0 / 35
Connection Type:Bridge
Service Name:br_0_0_35
Service Category:UBR
IP Address:Not Applicable
Service State:Enabled
NAT:Disabled
Firewall:Disabled
IGMP Multicast:Not Applicable
Quality Of Service:Disabled

I tried to connect using PPPoE, using my Sonic username and password to authenticate, but again didn’t get a connection.

When my 2Wire successfully makes a connection, it has this configuration:

DSL Line Selection : auto
ATM Circuit Identifier : VPI: 0 VCI: 35
ATM Encapsulation: LLC
ATM PVC Search : enabled
Connection Type : Direct IP (DHCP or Static)
no PPP settings (incl user/passwd)
Use built-in hardware (MAC) address
Obtain IP address automatically
Obtain DNS info automatically
Line 1 (inner pair)
protocol G.DMT
PVC Info: 0/35
Conn Type: direct IP
Internet Address: 173.228.18.15
Subnet Mask : 255.255.255.0
Default Gateway: 173.228.18.1
Primary DNS: 208.201.224.11
MTU: 1500

Can you tell me what parameters might be wrong for the 520B, and what they should be? Does Sonic have to do something to enable the 520B to connect?

Thanks,

Dave
by rlvh » Sat Aug 13, 2011 11:28 am
Bridge mode is the correct mode to use. The internet light will not turn on when it is in bridged mode though.
by davekohr » Sat Aug 13, 2011 1:39 pm
Thanks. So the bridge mode part of the config is correct. But it still isn't getting a connection, when I connect a laptop to it with Ethernet the laptop can't reach the Internet.
by davekohr » Sat Aug 13, 2011 10:48 pm
I figured out the problem. It seems the default, when the modem auto-configures itself, is for it to run a DHCP server when it's in bridge mode. So the computer gets assigned an IP address on the 192.168.1.0 network instead of Sonic's, and nothing works after that. When I turned off the DHCP server, everything works fine. Seems like a bug in the modem firmware, I'll have to see if there's an update.

Thanks to rlvh for responding.
by mufumbo » Tue Oct 04, 2011 2:04 am
i have removed the dhcp server and configured in bridged mode
5 posts Page 1 of 1

Who is online

In total there are 5 users online :: 2 registered, 0 hidden and 3 guests (based on users active over the past 5 minutes)
Most users ever online was 422 on Sat May 26, 2012 5:28 am

Users browsing this forum: Baidu [Spider], bubba198 and 3 guests