10Gb Internet

Internet access discussion, including Fusion, IP Broadband, and Gigabit Fiber!
16 posts Page 1 of 2
by pzado » Wed Mar 29, 2023 2:51 pm
So I have the 10Gb FTTH plan and for some reason cannot get symmetrical speeds. In other words I get download speeds anywhere from 7-8Gbps but upload speeds never get above 1.2-1.7 Gbps. Needless to say I have tried every cable combination, test protocol, browser, methodology that I can think of. I have also not played around with any setting so as to have artificially set a cap on upload, but maybe there is a setting I need to play with to fix. Note that these speeds are the same regardless if I am connected directly to the Sonic modem or whether I go through my Unifi Dream Machine router.

Is anyone having similar issues? Happy to share hardware data and methodologies but don't know why this would matter since I am getting incredible download speeds. Any help is greatly appreciated.

by iaincole » Wed Mar 29, 2023 3:49 pm
I am having similar issues, speed testing to Sonic's speedtest server.

8.1Gbps is the theoretical maximum for TCP and I'm getting that for download speeds (like you are) but the upload speeds are much more inconsistent ranging from 3-6 Gbps usually (I have seen 7Gbps once)

I've tried 2 different NICs and I've been both directly into the ONT and via my router and they all have the same characteristics.

Maybe it's actually the speedtest server itself? :D
by syntaxsid1 » Thu Mar 30, 2023 2:52 pm
We do send symmetrical speeds but the TCP overhead will skew both of these numbers so they'll never read the FULL 10Gb. Upload more so since it's mainly upload you are using to communicate with the speed test server. All should be fine unless of course you are getting less than 1Gb in either direction on your test with an idle network. If you feel there is a larger problem, absolutely reach out to our support team so we can investigate on your behalf. Have a great day!
Jeff M. with Community Escalations @ Sonic
by dane » Thu Mar 30, 2023 2:59 pm
One issue with speed test tools is that they’re generally set up with the assumption that all connections are asymmetric. So the data downloaded, the test payload, will be much larger than the test payload for an upload test. So, for example, the test might download 100 MB but only upload 10 MB. The result seems to be that the upload never really gets up to speed before the entire payload is completely sent.
Dane Jasper
by iaincole » Thu Mar 30, 2023 3:31 pm
Well I'm using the ookla speedtest server hosted by Sonic, so hopefully you've configured it to handle the expected speed from the 10Gb service. I don't think I'm hitting the "payload too small" issue since the duration of the upload test is the same regardless of the speed it's reporting. I just did a few tests and got varying results on upload from 3-6Gbps but they were all 5s long. For each of these tests the download was solid and consistent ~8Gbps

syntaxsid1 wrote:
Upload more so since it's mainly upload you are using to communicate with the speed test server.

I'm not really sure what you mean by this. I would expect sending and receiving data to be the same on a synchronous network unless there are some differing TCP settings on either either end. Is it possible the Sonic speedtest server isn't capable of receiving data at 10Gb/s? this seems unlikely.

The other thing that's puzzling is the inconsistency. If it's expected that upload is slower than download for whatever TCP reasoning, it should at least be consistently slower, however I'm seeing quite a lot of variance in the upload test and I'm not seeing any variance in the download test.

I already have a ticket open about this but I'm posting here as well in case anyone else has any ideas
by virtualmike » Thu Mar 30, 2023 3:45 pm
Perhaps you could create a larger file and upload it to your account's file space using FTP?
by iaincole » Thu Mar 30, 2023 4:00 pm
virtualmike wrote:
Perhaps you could create a larger file and upload it to your account's file space using FTP?

I don't think I have any FTP space with my service
by virtualmike » Thu Mar 30, 2023 4:29 pm
Oops. Well, never mind!
by msiegen » Thu Mar 30, 2023 6:33 pm
Inability to max out the upstream seems to be common experience, and not only at Sonic. I've seen similar reports about AT&T and Bell Canada in other forums, most often from users who are connecting their own routers instead of an ISP provided one.

One solution that has worked for some is to rate limit their egress traffic slightly below the maximum that the fiber can handle. If you're comfortable with a Linux shell, there are some examples here and one report that it worked for another Sonic customer here.
by dane » Thu Mar 30, 2023 7:31 pm
You’d need to use the Ookla native app for decent results. A browser is just too slow.

But even the version we host is testing a lot less data for upload than download. It’s not something we can configure in their platform.
Dane Jasper
16 posts Page 1 of 2

Who is online

In total there are 12 users online :: 0 registered, 0 hidden and 12 guests (based on users active over the past 5 minutes)
Most users ever online was 999 on Mon May 10, 2021 1:02 am

Users browsing this forum: No registered users and 12 guests